turbo timer problems - Patrol 4x4 - Nissan Patrol Forum
Patrol 4x4 - Nissan Patrol Forum, Photos, Directory

 


Go Back   Patrol 4x4 - Nissan Patrol Forum > General Technical Discussions > Auto Electrical

Patrol4x4.com is the premier Nissan Patrol Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-02-2011, 08:44 AM
Newbie
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default turbo timer problems

recently installed a turbo timer in my 03 gu ute, and the sub tank light stays on the dash any ideas as to what ive wired up rong, timer only has an earth, power, ignition and acc wires??
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-02-2011, 08:46 AM
DannyG's Avatar
Senior Member
 
Join Date: May 2010
Location: Westbury Tasmania
Posts: 127
Thanks: 0
Thanked 3 Times in 3 Posts
Garage
Default

Here ya go mate.....taken from another thread Easy Turbo Timer and Sub Tank Solution



I recently installed a Bogaard turbo timer and like a lot of people that I am now reading about, I had the subtank light come on and the pump stopped working.

I have since searched these forums and see that people with the same problem have been told the right advice and that is to use a diode or relay in the system, but I havent seen anyone explain it to dummys like me so we can easily do the wiring ourselves.

First of all, if you want to use a turbo timer and havent yet bought one, get the simple plug and play version designed for GU's and you wont have this problem!!

However if you are like me and you have a 3 wire turbo timer here is what you do.

On my Bogaard model BES-124ST-1 it has a red wire which is for permanent 12v positive.
A blue wire which is for the Ignition. And of course a black wire which is earth.

My ignition barrel had a large 12v permanent red/white wire, a blue wire for ignition and I used a chassis earth separate from the barrel. Of course your multimeter would be used to confirm you are tapping into the correct wires.

The problem occurs because the subtank computer needs accessory power when the engine is running otherwise it thinks there is a problem and the computer disables the pump and makes the light on the dash stay on.

Wiring the turbo time in the manner it calls for clearly creates the problem when you turn your vehicle off and it then runs on the timer.....so the pump no longer has the power it needs while the vehicle is still running.

The solution is simple.

Get yourself a relay. Tap into the blue wire on the timer and run that to '86' on the relay. Run a wire from '87' to accessorys, '85' is earth and '30' is 12v permanent power.

This will keep the accesory power to your computer while your on the timer waiting for it to shut down. No more problems

I hope this helps others like me who know very little about auto electrics...or just enough wire in a turbo timer and not realise the sub tank runs off the ignition!
__________________
GU Patrol 4.2TD
Sold GU 4.5 Petrol/Gas...thirsty



Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On







Subscribe in NewsGator Online


All times are GMT +10. The time now is 12:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.