squealing noise coming from turbo - Patrol 4x4 - Nissan Patrol Forum
Patrol 4x4 - Nissan Patrol Forum, Photos, Directory

 


Go Back   Patrol 4x4 - Nissan Patrol Forum > General Technical Discussion Forums > Engine & Drivetrain

Patrol4x4.com is the premier Nissan Patrol Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-05-2019, 03:25 PM
JJ4 JJ4 is offline
Newbie
 
Join Date: May 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default squealing noise coming from turbo

I have a 2009 Nissan Patrol 3.0 litre diesel with a ZD30 engine which has done 160,000km
It has just started making a squealing noise between 1500 and 2500rpm and seems to drop off outside of this rev range. Initially I thought it might be a belt, but after closer inspection it seems to be coming directly from the turbo. Funnily enough when I take off the vaccume house from the gate valve it stops completely. Have never experienced this before. Anyone out there experienced this before?? Would love to hear your thoughts
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-05-2019, 03:36 PM
geeyoutoo's Avatar
I Am Me and I Love My ZD30

 
Join Date: Apr 2010
Location: Sunshine Coast/US
Posts: 40,994
Thanks: 6,531
Thanked 10,934 Times in 7,269 Posts
Garage
Default

Quote:
Originally Posted by JJ4 View Post
I have a 2009 Nissan Patrol 3.0 litre diesel with a ZD30 engine which has done 160,000km
It has just started making a squealing noise between 1500 and 2500rpm and seems to drop off outside of this rev range. Initially I thought it might be a belt, but after closer inspection it seems to be coming directly from the turbo. Funnily enough when I take off the vaccume house from the gate valve it stops completely. Have never experienced this before. Anyone out there experienced this before?? Would love to hear your thoughts
Could be a few things, the CRD is not unknown to get the odd exhaust manifold leak which can result in a squeal at different revs but will often shut up when engine heats up, you mention vacuum hose, you don't mention what boost control you have so it is a bit hard to put all facts together, a damaged/leaking vac hose can cause a squeal, so to rule that out I would check every vacuum hose between the turbo and the vacuum pump. Put up a pic of this 'gate valve' you speak of.
__________________
I Like a Tidy Forum - 2000 ZD30 with a few bits and a New Eclipse Turbo
My Album - My Ongoing GU Mods - My Channel - My Garage - Harley. Performance Tech
ZD30DI Tech Archives - NADS, So You Bought a ZD30
- Powercurve.com.au
Boost Control Now by Digibooster - Domestic Violence Has No Excuse.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #3  
Old 11-05-2019, 04:33 PM
JT54's Avatar
Senior Member
 
Join Date: May 2014
Location: Rural Southern Tablelands, NSW
Posts: 418
Thanks: 180
Thanked 147 Times in 113 Posts
Default

Quote:
Originally Posted by JJ4 View Post
I have a 2009 Nissan Patrol 3.0 litre diesel with a ZD30 engine which has done 160,000km
It has just started making a squealing noise between 1500 and 2500rpm and seems to drop off outside of this rev range. Initially I thought it might be a belt, but after closer inspection it seems to be coming directly from the turbo. Funnily enough when I take off the vacuum house from the gate valve it stops completely. Have never experienced this before. Anyone out there experienced this before?? Would love to hear your thoughts
Mine 08 CRD @ approx 140,000ks, had metallic squeal noise, thru rev range and sounded like coming from turbo, removed inlet duct and noise really sounded like it was coming from turbo. At idle, the noise was present and stopped when the vac line was removed from VNT actuator or when the needle valve(eg:manual boost control) was unwound "reduced boost" and noise stopped. Changed out turbo and noise still there, ended up being a warped exhaust manifold and the first two studs had failed. Machined exhaust manifold / new gasket/fitted Inconel studs and copper coated wurth lock nuts and then problem fixed. Price a new manifold, understand they are a good price.
__________________
2008 GUIV WAG ST Manual CRD - To do the job
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squealing noise under load on cold CRD shickered Nissan Patrol GU/GR Y61 21 03-08-2013 11:17 AM
Turbo noise? Tobias 3 Litre ZD30 DI Engine 13 25-12-2012 03:22 PM
Oil coming out of turbo jonesy383 Nissan Patrol GQ/Y60 & Ford Maverick 12 28-09-2012 07:50 AM
Ticking Noise Baron General Patrol Discussion 0 30-05-2010 07:42 PM
Turbo noise? MqSD33 Nissan Patrol GQ/Y60 & Ford Maverick 4 09-10-2009 08:03 PM






Subscribe in NewsGator Online


All times are GMT +10. The time now is 10:31 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.