Patrol 4x4 - Nissan Patrol Forum banner

problem

  1. Nissan Patrol GU/GR Y61
    Hello Everyone I have a 2005 (new trim) GR Y61 1st Generation ZD30 Patrol and not 2 moths in and I've already manage to screw something up! I replaced the Stereo/DVD/GPSnav with a new stereo and in doing so I had to rewire the ground/negative wire since I was not able to find it in the original...
  2. Nissan Patrol GU/GR Y61
    2003 GU ZD30 I just replaced both Parker headlight T20 bulbs with leds, now they aren’t turning on with the headlights but completely turn on when I indicate, but they don’t flash, then turn off as soon as the indicator turns off. Somebody said I may need a resistor?
  3. Nissan Patrol GU/GR Y61
    Hi guys, just bought a Y61 3.0 Patrol GR 2003. Experiencing some vibration problems on the front left (nearside) and I have attached some pictures of the offside and nearside. One axle is leaking in my opinion and the other seems bone dry?? The vibration and noises are when coming to a stop or...
  4. Nissan Safari
    Hello guys i recently changed my clutch plate not the pressure plate. i have put a exedy clutch.. and then after some time did not drive more than 4000km when i press the clutch there was some silly noise coming from the clutch so i checked and the clutch is new but that springs are in the...
  5. Engine & Drivetrain
    Hello fellow patrollers, My problem may be normal and I'm just paranoid, but I have a tb42 carby straight petrol. And recently I replaced water pump and radiator cap then topped up the system. I'll say up front that the water to coolant ratio is high so it is probably 90% water. Now on hot...
  6. Engine & Drivetrain
    Starts good when cold but when hot: Any ideas? https://youtu.be/FcQ7E5vjeOw
  7. Auto Electrical
    Driving home from work the other day, i lost power to whole dash instrument, all gauges stopped working, as well as my electric windows. dash lights, parkers and tail lights still work, Same as indicators and wipers. I replaced the fuse but every time i turn on the ignition the fuse blows. Has...
  8. Auto Electrical
    (1991 TD42 GQ TI) Hi guys, today I took my alternator out to give it a full clean out. Previously it was giving me about 12.9v at idle with no major electrics running and barely keeping up at 12.6 with headlights on. So I cleaned it out today hoping to get a few more volts out of it. Problem...
  9. Nissan Patrol GQ/Y60 & Ford Maverick
    Hi, I need some help I e searched everywhere and can't find any answers. I have a 95 safari with 172xxx km on it. Changed the atf recently, cycled it through with shell spirax s5 fluid (drain pan and refill, run vehicle for two minutes and repeat 3x) new gasket and filter. Used about 15 quarts...
  10. Auto Electrical
    Hi guys, after extensive head scratching and searching through posts on here I thought it was time to contribute to this great site and see if you guys could help me a little. I recently started having troubles with the alternator on my td42 gq. Charge light came on and voltage dropped...
  11. Engine & Drivetrain
    Hi all, I have a problem with my 99 GU 2.8 TD 270 000kms. It did have a starting issue. I recently installed an advance plate from Nizz Bits. Now I have a bigger starting issue - When I start the car it has to turn over around ten times before it will start and then blows black smoke for about...
  12. Nissan Patrol GQ/Y60 & Ford Maverick
    For a few years now, the rear brake/tail lights have been turning on by themselves with the key out and the vehicle switched off (a Nissan Patrol GQ SWB). Recently we looked into the problem and disconnected the pushrod censor from the brake pedal, however despite this the brake lights still go...
  13. Nissan Patrol MQ/MK 160/260 series
    hello, recently bought a landrover with an sd33 engine and box out of a rusted through patrol fitted. she was driving great but hard to start, after a bit of research i found the most obvious conclusion was shot glow plugs so i decided to take one out to find out which ones i needed as i wasnt...
  14. Nissan Patrol GQ/Y60 & Ford Maverick
    Hey everyone, ive got some seriously frustrating clutch problems. for ages the clutch in my 1990 GQ TD42 would slip when it was warm and under load so i have replaced it with a real decent heavy duty one. only problem now is i cannot get it to disengage... this is really frustrating me now i...
  15. Nissan Patrol GU/GR Y61
    Hi all, I brought a 2010 Nissan Patrol DX GU 6 CRD around 2 weeks ago. It was running fine until one day it started struggling to start. It happened a couple of times during 1 week and i managed to get it going. It has had a dual battery setup in the past that has been disconnected but still has...
  16. Engine & Drivetrain
    Hi just wondering if anyone out there knows how tell if your diesel injectors are gone? I recently took it to a diesel mechanic who wasn't to sure. His comment was either the injectors or the ecu. Anyway I got new injector noozles on now which did improve fuel economy but as for power not much...
  17. Engine & Drivetrain
    Hi, Ive had the Donator speed box chip on my 98 2.8 diesel for about 6 months now, but a problem has just showed its ugly face. I have wired the chip in with a switch going to the dash on the power wire for better control, it has always worked well for a quick boost of power when needed...
  18. Nissan Patrol GU/GR Y61
    I have trolled GU and GQ forum threads for hours. Can find a couple of GQ threads with same problem but no solutions. If there is a GU thread on this, please point me in the right direction. Ok, here goes. GQ td42ti engine into GU2-auto body (ex 3.0 tdi) All works except auto lock-up not...
  19. General Patrol Discussion
    hey i just bought a GU patrol and took it out for a strap last night and i noticed that when i put it back it 2wd the 4wd light on the dash would stay on and it went off as i drove off, at one point it stayed in 4wd and would not go back to 2wd, has anyone had this problem before
Top