Patrol 4x4 - Nissan Patrol Forum banner

1 - 9 of 9 Posts

·
Registered
nissan
Joined
·
36 Posts
Discussion Starter #1
Guys I apologise for the long post but, I am hoping somebody out there can help me, my 2.8 GU is full on giving me the ****s, starts fine no dramas runs fine go for a drive, 40k in one instance had it idling whilst helping a mate out on the side of the road fix his problem go to take of no power then stops can only be a few issues I tell myself I start at fuel pressure at the lift pump/filter zero nothing I know its full as a week ago I filled it. No drama pump up pressure of I go does it again and again till I limp her home. Change the filter replace all the hose clamps drive around town for the weekend (no dramas) then next weekend go for a try it drive 30ks, this time no dramas stop let it idle and go to take off and same problem. This time I take note of how hot the top of the Injector pump is I cannot leave my hand on it it is that hot. Anyway get it home again (strangely enough after the 4th stop and prime it actually ran fine). So I pull the return line of the back of the pump and it is simply just dribbling. Is this normal? as I would have thought that there would have been a bit of pressure returning to the tank. Any help or ideas will be appreciated. Oh it has 380000ish on the clock.
Thanks in advance.
 

·
Registered
nissan
Joined
·
2,863 Posts
Isn't there a cam sensor or crank sensor or something built in to the sides of these pumps? Maybe that's playing havoc given the heat?

I wouldn't expect the fuel return to the tank would be under any real pressure - even on a commonrail system, but that's based solely on the injector test kit we have at work.
 

·
Registered
nissan
Joined
·
36 Posts
Discussion Starter #3
Ok more to the saga now there is NO fuel returning to the tank now. The obvious cause would appear to be the low pressure side of the pump (if there is such a thing) is stuffed hence I assume the pump is no good anymore. Has anybody else experienced this ? if so what was the cause?

Thanks.
 

·
Registered
Joined
·
778 Posts
No fuel coming from the return line means you have a supply system issue (air in it or fuel restrictions) or a pump issue. Check the simple things first.

Andy
 

·
Registered
nissan
Joined
·
36 Posts
Discussion Starter #5
Checked everything I could think of there is fuel coming from the the returm line from the injectors but nothing from the pump. So im assuming the pump is buggered unless there is something im missing. Im really hoping its not the pump as I have poured to much coin into the 2.8.
 

·
Registered
nissan
Joined
·
36 Posts
Discussion Starter #7
Fuel returns from the injectors to the back of the pump which has a bango fitting that that im assuming circulates the fuel in the head of the pump to cool it then returns all excess to the tank. Im pretty sure I have answered my own question here but im keen to know if anybody else has experienced this hopefully its not the pump, wishful think tho
 

·
Registered
Joined
·
2 Posts
Checked everything I could think of there is fuel coming from the the returm line from the injectors but nothing from the pump. So im assuming the pump is buggered unless there is something im missing. Im really hoping its not the pump as I have poured to much coin into the 2.8.
 

·
Registered
Joined
·
2 Posts
Hey mate i no its a long time and i have a 2.8 patrol and myne idles fine just hick ups and lose power never stops just splutters a bit and then comes good doesnt seem to be sucking air so mechanic says any info would be appreciated cheers
 
1 - 9 of 9 Posts
Top