Patrol 4x4 - Nissan Patrol Forum banner

1 - 17 of 17 Posts

·
Registered
Nissan
Joined
·
1,671 Posts
Discussion Starter · #1 ·
The old girl is boosting upto 15psi it has never gone past 12psi before. The only thing I have done is disconnected the battery for a reset for about 18hrs. Is this a problem? I don't think it could hurt it at that psi but could it? Also the egts are up about 20deg as a result
Cheers
Troy
 

·
Registered
Nissan
Joined
·
6,063 Posts
Boost is only mechanically controlled by the actuator on the turbo.

I would start by making sure the waste gate moves freely and is not jammed. Then follow the hose from the actuator to make sure it's not kinked or damaged.

Cheers

Justin
 

·
Registered
nissan patrol
Joined
·
587 Posts
s**t troy is having trouble with his 2.8 and doesnt know what it is....we're doomed then :p
 

·
Registered
Nissan
Joined
·
1,671 Posts
Discussion Starter · #4 ·
I would definitely not say I'm a wealth of knowledge. Everything I know comes from this forum. The forum is the wealth of knowledge. Is there a way of testing the actuator as I did drive through salt water today.
Cheers
Troy
 

·
Registered
Nissan
Joined
·
1,671 Posts
Discussion Starter · #5 ·
A bit more info. 1st and 2nd gear normal boost. Under full load. 3rd to 5th just hitting 15psi revving to 4500rpm. I will disconnect the actuator tomorrow and check the wastegate. I had a look at the actuator and there is a bit of dried rusty water coming from the hole underneath it.
Cheers
Troy
 

·
Registered
Joined
·
346 Posts
Extreme High Revs.

A bit more info. 1st and 2nd gear normal boost. Under full load. 3rd to 5th just hitting 15psi revving to 4500rpm. I will disconnect the actuator tomorrow and check the wastegate. I had a look at the actuator and there is a bit of dried rusty water coming from the hole underneath it.
Cheers
Troy
OMG, 4,500 revs ???? :eek: Crikey, what are you doing with that truck ?
Rarely if ever, do I need to go over 3,000 AND that's towin a camper trailer, you do realise, your getting close to the max with that ?
 

·
Registered
Joined
·
2,762 Posts
OMG, 4,500 revs ???? :eek: Crikey, what are you doing with that truck ?
Rarely if ever, do I need to go over 3,000 AND that's towin a camper trailer, you do realise, your getting close to the max with that ?
4,500rpm that's nothing redline over 5,000rpms!
Have been up there a few times!!!
 

·
Registered
Nissan
Joined
·
1,671 Posts
Discussion Starter · #11 ·
I only went that rpm to check the amount of boost it's getting. Normally I would only go to 3000to3500 myself. But a good squirt every now and then won't hurt it. I'm about to pull the actuator arm off the wastegate and check for movement. I hope it moves freely or I might be up for a new turbo.
 

·
Registered
Nissan
Joined
·
1,671 Posts
Discussion Starter · #12 ·
The wastegate was a bit tight but a little fiddling it came good but still overboosting. I don't think it's the actuator as I was told it would come on boost much faster than normal but it doesn't. It was also hard to get actuator rod back on the wastegate. The question is has this been doing it all the time as when I disconnected the battery It cleared the boost alarm which it never came on before so I'm unsure if it was set. Having a free flowing exhaust, would that increase the boost that much? Any import is appreciated.
Thanks
Troy
 

·
Registered
Nissan
Joined
·
6,063 Posts
OMG, 4,500 revs ???? :eek: Crikey, what are you doing with that truck ?
Rarely if ever, do I need to go over 3,000 AND that's towin a camper trailer, you do realise, your getting close to the max with that ?
4000 Plus revs at least once a day usually in second gear but sometimes just for fun in third ;)

Cheers

Justin
 

·
Registered
Nissan
Joined
·
6,063 Posts
The wastegate was a bit tight but a little fiddling it came good but still overboosting. I don't think it's the actuator as I was told it would come on boost much faster than normal but it doesn't. It was also hard to get actuator rod back on the wastegate. The question is has this been doing it all the time as when I disconnected the battery It cleared the boost alarm which it never came on before so I'm unsure if it was set. Having a free flowing exhaust, would that increase the boost that much? Any import is appreciated.
Thanks
Troy
I didn't know there was a boost alarm/sensor!

Might have to look that one up.

Cheers

Justin
 
1 - 17 of 17 Posts
Top