Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
757 Posts
Discussion Starter #1
Hello all

Every now again the old girl doesnt like turning off (cleanly) when i turn the key. I have replaced the fuel shut-off solinoid but is still have the same issue. After talking to my machanic he suggested i refit the butterfly in the throttle body. Even though i dont think this is the cause i have refitted it.
My question now is does anyone now when the butteyfly should operate? does it work at a set engine temp? i cant get mine to operate at the moment. I have removed the vacuum switch and tested if electriclly and it works fine. I have vacuum at the switch and if i such on the hose going to the butterfly i can get the flap to shut.
So it seems my issue is i dont know what send the power to operate the switch and when.
Does anyone know?
 

·
Registered
Joined
·
2,762 Posts
All I can add is I have disconnected the butterfly ages ago without any I'll effect.
I understand it's use is for deceleration backpressure in intake i think?!? etc.
 
nissan patrol y60
Joined
·
433 Posts
When u replaced fuel cut solenoid was the old 1 perished if so did u remove all broken bits as might be holding new 1 open.
 

·
Registered
Joined
·
757 Posts
Discussion Starter #4
i have only been having this issue since i had the injector pump overhauled. I'm like you i have had the butterfly removed for years with no issue.
The fuel shut-off solenoid i replace was new so the o-ring came out cleanly.
My machanic has looked at it several times with no luck and as these faults seem to never happen when it in the workshop i'm not sure he thinks its that big a problem.
Maybe i will remove the second new fuel solenoid and had a look at it.
 
1 - 4 of 4 Posts
Top