Patrol 4x4 - Nissan Patrol Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
G'day all,

I've just fitted a set of 285's to my little 2.8 and with the rising number of speed cameras out and about I don't want to get caught out because my speedo is out. Besides using an ecutalk what are the other ways of correcting the speedo on the 2.8. Have thought about one of the mark's adapters speedo boxes. There is a thread on here which outlines how to correct the speedo by changing the gear at the gearbox but I didn't think it applied to the 2.8 from what I read.

Cheers
Dave
 

·
Registered
nissan
Joined
·
528 Posts
if you are running 285's (33's) your speedo will likley be correct. I have had three, and all have run true with 33's. get a gps which will provide real time speed check (reasonably accurate) or do the 5km speedo check on the high way. Dont just check the odo distance. get the rig to 100km/hr and have a mate time the distance of 5km and some simple maths will allow you to check. the first patrol I owned I took it to RACQ and for a very nominal fee they checked it on their callibrated dyno and gave me a certificate to say it was within 2% of correct at 100km/hr. any dyno can do this if it has recently been callibrated?
 

·
Registered
Joined
·
87 Posts
Discussion Starter #3
Thanks 1200ob,

I have put the gps on a few times although it has only been up to 90km/h max i need to do a highway run to check it at 100km/h. There seems to be a lot of fluctuation in the gps though. At dead on 60km/h it seems to be saying about 64/65km/h. I shall look into the speedo calibration through racq.

Cheers
Dave
 
1 - 3 of 3 Posts
Top