Patrol 4x4 - Nissan Patrol Forum banner
1 - 7 of 7 Posts

·
Registered
nissan
Joined
·
14 Posts
Discussion Starter · #1 ·
Bought a 1999 patrol wagon 2.8 turbo last weekend, drove all week did about 250 klm, Friday night put some diesel in and 40 klm later it stalled, had to wait 5min abefore it started again, did this 3 times till I got it home. Saturday morning could not get it to fire up, so put a new filter on it and she fired up straight away it ran smoothly for about 2-3min and just cut out, Bleed the system up to the bleed screw at the in side of fuel pump, ran for another 2-3 min and cut out. Cracked all the injector lines at the head and bled, again fired up and ran for about 3-4 min and cut out ?? so know I'm stuffed could it still be air, or is it the pump playing up.
Every time we got it running it ran very smoothly, and would cut out like someone turned the key off.

any suggestion would be appreciated

cheers
 

·
Patrol 2.8 TD
nissan patrol
Joined
·
1,640 Posts
Wish i could help mate, I had an almost identical issue yesterday, but undoing the wingnut and bleeding the line worked for me.

Hope it turns out to be a cheap fix
 

·
Registered
nissan
Joined
·
14 Posts
Discussion Starter · #4 ·
Found problem - on the air intake there is a sensor of some sort when this is disconnected the car fires up straight away but when connected its a no go.

cheers
 

·
Registered
nissan
Joined
·
14 Posts
Discussion Starter · #6 ·
Just an update on this it may come in handy for some in the future.
*With maf connected car would not start .
* disconnect maf start car connect maf while car running it would stall after 2 to 5min.
* We replaced maf and problem persisted.
Sent car to diesel mechanic, put a machine on to read fault code, 3 codes come up, these were cleared and still could not fix start problem. Took car to nissan, nissan said computer only getting 5v instead of 12volts, nissan sent car to auto electrician the elect found 2 bad connections, one on the ecc and one on th ecm. Problem fixed labour was our only charge as there were not parts required.
cheers
 
1 - 7 of 7 Posts
Top