Patrol 4x4 - Nissan Patrol Forum banner

1 - 18 of 18 Posts

·
Registered
nissan
Joined
·
32 Posts
Discussion Starter #1
2003 ST 3ltr TD manual.
I have just replaced the engine, clutch, exhaust, turbo, radiator and repaired the inter-cooler. When driving on the highway in 5th between 90kph and 110kph, I put my foot down to speed up but I can put my foot flat to the floor and it does nothing. I take my foot off the accelerator and immediately accelerate and it takes off.

Any ideas? Main concern is obviously is it dangerous to the engine.....

David Siacci
 

·
Premium Member
nissan
Joined
·
2,256 Posts
Possibly over boosting and going into fail-safe mode.

Do you have a boost gauge fitted?
 

·
Currently in PAD rehab
Joined
·
18,407 Posts
Possibly over boosting and going into fail-safe mode.

Do you have a boost gauge fitted?
+487,763

Why was the engine replaced?

Boost gauge will give you the best idea, but my money is on Yendor's answer.
 

·
Registered
nissan
Joined
·
546 Posts
Its overbosting, get some gauges in the big girl, dawes valve and the other mods that are rec on here.
Block the egr and fit a dawes valve, the diff to your car will be unreal.
Or if you want a laugh at modern tech, fit the boost gauge and monitor what the computer does with the control of the boost!!
Hope you get it all sorted, what did the full rebuld cost do you think? How many kays had it done before the build?
Cheeers
zappa
 

·
Registered
nissan
Joined
·
32 Posts
Discussion Starter #5 (Edited)
Last year in October the engine started using water. Ended it was a cracked head, then the turbo had to be replaced due to it whining badly, bearing went or something. The inter-cooler had to be repaired as it had a leak. That was at 185,000k. Cost $7200.

4 weeks ago I was driving along the freeway and the engine dropped back to idle. I pulled over and the temp gauge went red hot. It then stopped and a heap of steam came out from under the bonnet. The mechanic had the head reco'd and the motor runs. At idle its perfect. Under load though #3 piston hits the head. The cars done 8,000ks since the last effort..

Got a new long motor from Nissan for 7500, had to replace the clutch 2300, plus labour. Haven't got the bill from the mechanic yet but I bet its gunna hurt. I stuck a 3" exhaust on it to see if it helps whilst the thing was in bits.

Where do I go looking for the boost gauge. I think I need a temp in and out as well as a sensor for the water bottle. Does someone make one specifically for the patrol.

I will have the boost checked.

Thanks

Dave Siacci
 

·
Go Hard or Go Home
Joined
·
3,197 Posts
Also read the reference doc from the sticky by Aksniss

http://www.patrol4x4.com/forum/niss...ference-document-zd30-owners-look-here-31418/

This document will explain how to stop the overboosting, also check your MAF voltages,
Post 5 by whitie in the same thread will show you how to measure the voltages, or get an ECUTalk which will read MAF voltages & much much more.

Installation cost of my long motor last year was around $1700-1800 but can be done for around $1500 from Nissan so I have been told.
 

·
Registered
nissan
Joined
·
546 Posts
There are some low water warning systems on ebay, aftermarket jobbies for a bout 200 bux.
Shame you have had such a bad run,when ALL the costs of rebuilding comes apparent you can see why people think about other engines!!
Zappa
 

·
Registered
nissan
Joined
·
32 Posts
Discussion Starter #8 (Edited)
Stuck a boost gauge in today. Boost through the gears gets up to 18psi.
On the freeway cruising at 100ks the thing gets up to 20+psi before it drops to 0 and I have no acceleration. It generally boost at 10 to 18 psi other wise.

In the manual I downloaded from the sticky post it mentions turning the screw 1 1/4 urns to drop the boost. Is this what others have done with replacing the exhaust to 3''?

Dave Siacci

Pictures in Album.
 

·
Registered
Joined
·
270 Posts
Notice you said you installed a 3 inch exhaust. This will be the cause as it allows the turbo to spool harder making more boost and coming on boost lower.

You need to undo the lock nut and adjust the stop/grub bolt downwards to decrease boost. Just do a half a turn at a time. Do not adjust the actual arm length. Just adjust the grub/stop bolt.
 

·
Registered
nissan
Joined
·
2,003 Posts
Stuck a boost gauge in today. Boost through the gears gets up to 18psi.
On the freeway cruising at 100ks the thing gets up to 20+psi before it drops to 0 and I have no acceleration. It generally boost at 10 to 18 psi other wise.

In the manual I downloaded from the sticky post it mentions turning the screw 1 1/4 urns to drop the boost. Is this what others have done with replacing the exhaust to 3''?

Dave Siacci
Yes...

The 3 inch zorst is causing the overboost as described in the bible. Not every 3 inch pipe will cause it on every vehicle as they are all slightly different.

Wind the VNT screw back a tad OR fit Dawes and needle valve.

I only had to go bout 1/2 a turn with the 3" exhaust but then about about a further full turn when the EGR block went on.
 

·
Registered
nissan
Joined
·
32 Posts
Discussion Starter #11
Roger that. Ta. I actually adjusted 1 full turn. The boost is now at 14 - 16 max. Mostly it is on 12 to 13 psi. When I do 100 and back off it goes up to the 14 - 16 and just sits there. I might drop it another quarter turn (when it cools down a bit) an hopefully that will bring it back to the 10 - 11.

Dropped that bloody circlip though......

Thanks all for your help.

Dave Siacci
 

·
Registered
Joined
·
270 Posts
I wouldn't adjust downwards more than you need to stop the opverboost limp mode. Higher boost (at safe levels) reduces your EGT's. You will find at 100km at 14psi your EGT's could be as much as 50degrees lower than running at say 10psi. Mine used to run around 13-14 and 350 degrees on the open road.
 

·
Registered
nissan patrol gu
Joined
·
1 Posts
I had the same problem with my nissan GU and had lots of different ideas given to me on how to fix it. The main one I was told was to replace the air flow sensor which I did but it didn't fix the problem. I recently saw a diesel mechanic who said the problem is that you just need a turbo adjustment. It costed me $100 and it took a couple of hours. I went to Diesel Australia Pty Ltd at Allgas Street, Slacks Creek - ph 3808.6988. I found them very knowledgeable and next time I come accross any problems with my engine, I will be asking for their assistance first.
My 4WD is running beautifully now.
 

·
Rogue
nissan gu patrol
Joined
·
20,212 Posts
I have the same issue, I just take the foot off the pedal and plant it again, it always works.
 

·
Go Hard or Go Home
Joined
·
3,197 Posts
I had the same problem with my nissan GU and had lots of different ideas given to me on how to fix it. The main one I was told was to replace the air flow sensor which I did but it didn't fix the problem. I recently saw a diesel mechanic who said the problem is that you just need a turbo adjustment. It costed me $100 and it took a couple of hours. I went to Diesel Australia Pty Ltd at Allgas Street, Slacks Creek - ph 3808.6988. I found them very knowledgeable and next time I come accross any problems with my engine, I will be asking for their assistance first.
My 4WD is running beautifully now.
I think you will find they adjusted the VNT limiting grub screw mate, just like in the reference document. You could have done it for free.

Ask them what they actually adjusted on the turbo and get them to show you. My money is on the grub screw.............
 

·
Registered
Joined
·
1,873 Posts
All of you guys that are having problems with the over boosting issue need to read documents in sticky, all of us that have added the the suggested Mods have had over boosting issues, they can be done at home and the money saved can be used to purchase required items. Also consider bypassing the ECU when you have the DAWES, Needle valve fitted.
 

·
Currently in PAD rehab
Joined
·
18,407 Posts
I still need to wind my grub screw down half a turn. i dont get limp mode, but i do get spikes upto 18-20psi when she spools up.

I need to find someone with small girlish hands to get in there to do it as my clod hoppers that have 5 thumbs on each cant get in there.. Ive even tried staring at it for 10 whole minutes and no change..
 

·
Registered
nissan
Joined
·
32 Posts
Discussion Starter #18
Well with my Boost. I have adjusted to 10 or so psi at 2600 rpm in 5th gear. Peaks mostly at 15 to 18 psi whilst accelerating. Hope this does the job. Don't have a temp gauge at this stage though.
The SAAS boost gauge I bought is a noisy little bugger though.

Thanks all. Been very helpful.

Dave Siacci
 
1 - 18 of 18 Posts
Top