Patrol 4x4 - Nissan Patrol Forum banner

1 - 6 of 6 Posts

·
Registered
nissan
Joined
·
110 Posts
Discussion Starter #1
I've Recently put a 4terrain clutch in my td42 shorty done prob 3000ks went 4wding it started slipping pretty bad. But if I put it in neutral and pump it a few times it's fine for about a minute then goes again. Would this be air getting in. Or master/ Slave shot???
 

·
Registered
nissan GU iv 2006
Joined
·
1,717 Posts
air in the system wont cause the clutch to slip, just hard to disengauge I would have thought. How was rear main seal, oil leaking onto clutch will make it slip. Is the rubber bung back in the bottom of the bell housing?? Water/mud will cause it to slip too. Other wise maybe defective clutch. just some thoughts.......
 

·
Sydoforumsuperfan :)
nissan gu patrol
Joined
·
8,929 Posts
There is another thread on this and the clutch wasnt fitted properley. Something to do with the fork ? Found it
Well looks like i was WRONG! There is no problem with the clutch at all. On models with a clutch booster there is an adjustment screw where the master cylinder bolts on to the booster. Effectively what im trying to say is, it was adjusted too far out and there was tension on the master cylinder piston before you even pressed the pedal, effectively holding the clutch from clamping completely and thus causing a slip. the booster looks quite new so maybe the previous owner had replaced it or something. I admit i was a little too hasty in blaming the poor old cluch.
 

·
Registered
nissan
Joined
·
110 Posts
Discussion Starter #4
No worrys thanks for the replies do you know what that thread was called???
 
1 - 6 of 6 Posts
Top