Patrol 4x4 - Nissan Patrol Forum banner
1 - 5 of 5 Posts

·
Registered
2009 zd30 GU patrol
Joined
·
5 Posts
Discussion Starter · #1 ·
Bought myself a second hand 2009 zd30 GU patrol recently and as we've been coming into summer have started to need the ac more. The car still blows cold air fine, there just isn't much of it. Any things that I should check. I've also been told that the australian GU's don't have a cabin filter.
 

·
Registered
All work done the hard way
Joined
·
565 Posts
Hey mate, I had exactly the same problem a while back- I had it serviced by a mobile auto fridgy and it made a hell of a difference. I think he replaced something or other- can't remember what, it was a long time ago now- and removed a lot of fluff and lint; it cost me about $600 but it was money well spent.
 

·
Registered
Joined
·
281 Posts
If it stops after 1 click it will be the resistor. Located under the dash and 2 minute job to change out otherwise might need a regas. Yeah I brought a cabin filter for my 08 st wagon and can't find where it goes either :/
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
56,110 Posts
Bought myself a second hand 2009 zd30 GU patrol recently and as we've been coming into summer have started to need the ac more. The car still blows cold air fine, there just isn't much of it. Any things that I should check. I've also been told that the australian GU's don't have a cabin filter.
No they don't have a filter generally, I bought one from nizzbits a couple of years ago and fitted it, wrote up how I did it in my build thread (see link in signature). Surprising how much crap can accumulate in the core so this could be a part of your issue. Note, the filter addition WILL have a small effect on maximum airflow, but not enough to worry us.

Hmmm, probably time I took the filter out and cleaned it.
 
1 - 5 of 5 Posts
Top