Patrol 4x4 - Nissan Patrol Forum banner

1 - 10 of 10 Posts

·
Registered
nissan
Joined
·
31 Posts
Discussion Starter · #1 ·
Today jumped in the patrol for a 300k round trip and had this really bad rotten egg smell and I mean BAD just thought it could have been a bad tank of gas so didn't worry to much.
Done some shopping went to start ... nothing the 2 month old battery was completely dead i didn't leave anything on puzzled i got a jump start and headed off home.
About 100k from home the smell got really bad and the patrol died I pulled over pulled the bonnet and the battery's smoking, leaking and swelling WTF pulled the neg terminal and waited until i was sure it wasn't going to blow. Called a mate he brought a spare battery and we connected it and no go :mad: so i checked the fuses and i found about 3 blown replaced them and tried again with success well that until the missus started to yell SMOKE!!! it was coming from the windscreen vents and inside the instrument cluster shut it down again and found the fuse marked BAT 7.5A ELEC PARTS had blown again.
So i tried a couple more times and it kept blowing but the motor still ran......

BUT heres the thing it wont run above about 1500 -2000 rpms cant tell exactly as there's no gauges working, anything above that and it has a fit cutting in and out really fast But the old girl got us home Veery slowly
Can anyone please tell me where i should start looking i had a quick look under the dash and didn't see any burnt wires and i really hope the battery didn't fry the computer???
or should i just take it to an auto elect and hope he doesn't bend me over lol
Cheers
Darren
 

·
Registered
Joined
·
3,195 Posts
i think you might find your alternator might be overcharging big time. the regulators probably stuffed. it might charge right when the revs are low but as you bring the revs up its overcharging and frying everything. thats why it wont rev past 2000. the ecu is probably copping a mouth full of charge and shutting down. dont start it up again,call a sparkie to come out and have a look
 

·
Registered
Nissan CRD
Joined
·
893 Posts
I think the Auto electrician may be a good direction for this one. Find out who does good work for a fair price.

Measure the voltage the alternator is putting out, should be around 13.8 volts. Also have a check of the looms to see if any are resting (melted) on a hot spot.
 

·
Registered
nissan
Joined
·
207 Posts
Sounds like there is a major short circuit somewhere that is sucking all the alternator power and then sucking the battery also.............the smell is probably the sulfuric acid? boiling and releasing sulpur dioxide/hydrogen sulphide? (rotten egg gas smell)

Auto electrician at least to isolate the short and then consider to fix yourself or let him do it. Good luck!
Anthony
 

·
Registered
nissan
Joined
·
31 Posts
Discussion Starter · #5 ·
I think the Auto electrician may be a good direction for this one. Find out who does good work for a fair price.

Measure the voltage the alternator is putting out, should be around 13.8 volts. Also have a check of the looms to see if any are resting (melted) on a hot spot.
Yep shes at the auto elec at the moment He agrees that its the alternator regulator over charged the battery but he looked worried about the smoke in the dash.
I will update the thread when i find out more
Cheers
 

·
Registered
nissan
Joined
·
31 Posts
Discussion Starter · #6 ·
Well a little update had a quick chat with the auto elec he says that every component hes checked so far is fried its not looking good :( ... You'd think that there would be some bloody over load protection!!! :rolleyes: he said that without the regulator everything could have had a dose of 24 volts.
Just one component is worth about $1500 :headwall:
He didn't go into details about whats gone yet so i hoping it sound worse than it is... yeah right like thats going to happen :rolleyes:
There goes camping on my only two weeks off during the year
Cheers
 

·
Patrol 2.8 TD
nissan patrol
Joined
·
1,640 Posts
What is it about the xmas break and trolls giving up the ghost man..
 

·
Registered
nissan
Joined
·
31 Posts
Discussion Starter · #8 ·
Ok so far were up for
-Alternator
-Battery
-Instrument cluster
-ECU (maybe)
Hes going to sent the ECU away to get tested maybe can be fixed dont know yet
Just gave Nizzbits a call not to bad prices but i will hold off until the ECU is checked.
I forgot to ask Nizzbits if they were new or second hand does anyone know if he only sells new stuff????
 

·
Registered
Joined
·
1,542 Posts
Ok so far were up for
-Alternator
-Battery
-Instrument cluster
-ECU (maybe)
Hes going to sent the ECU away to get tested maybe can be fixed dont know yet
Just gave Nizzbits a call not to bad prices but i will hold off until the ECU is checked.
I forgot to ask Nizzbits if they were new or second hand does anyone know if he only sells new stuff????
Not sure who you are talking to but I know nothing about this??????
 

·
Registered
nissan
Joined
·
31 Posts
Discussion Starter · #10 ·
Not sure who you are talking to but I know nothing about this??????
Ohh DAMN Sorry about that
First i called Nissbits and was told that he wasn't you and couldn't help me then he gave me what i thought was your number 93999771 .... which in fact is a Nissan wrecker i have just found out DOH

So can you help me with the above parts for a TB45 ???
Thankyou Sorry for the confusion
 
1 - 10 of 10 Posts
Top