Patrol 4x4 - Nissan Patrol Forum banner

1 - 12 of 12 Posts

·
Registered
nissan
Joined
·
804 Posts
Discussion Starter #1
Hey guys ive noticed my air con hasnt been working to well the last month or so. And today when driving on the highway i stopped and kept going the air con didnt really work when i stopped. I checked to see if there was gas in the lines and there was. Some bright yellow green gas came out. Im a dumb founded why it wont work. Any help would be good
 

·
The Centaur .5 Manpopwer .5 Horsepower
nissan
Joined
·
981 Posts
Ashley, what year is your patrol? Our 2012 crd had a/c issues when the vehicle was stopped as well, found out Nissan had removed the thermo fan for the a/c condenser, thus it didn't work as it should when stationary, the vehicle needed to be moving to work well. Our 07 crd had the thermo fan so don't know why they removed it for our 2012.
 

·
Registered
nissan
Joined
·
804 Posts
Discussion Starter #5
Ive got a 2004 the thermo fan still works i think. But its not very cold when moving either
 

·
Registered
nissan
Joined
·
804 Posts
Discussion Starter #9
Ive got the filters for the aircon mod i might do that and it will give an a chance to have a look at the evaporator
 

·
Registered
nissan
Joined
·
804 Posts
Discussion Starter #10
So i fitted the filters and had a look at the evaporator and it was filthy so i got the air compressor out and blew a bunch of it out but there was mud at the bottom of. So i got my weed sprayer and sprayed a couple litres of soapy water in there and the drain was half block so used whipper snipper wire and the air compressor to free up the outlet. Im gonna flush it out again on the weekend and try get all the mud off the bottom
 

·
Registered
Joined
·
3,472 Posts
So i fitted the filters and had a look at the evaporator and it was filthy so i got the air compressor out and blew a bunch of it out but there was mud at the bottom of. So i got my weed sprayer and sprayed a couple litres of soapy water in there and the drain was half block so used whipper snipper wire and the air compressor to free up the outlet. Im gonna flush it out again on the weekend and try get all the mud off the bottom
Try this:

Mizu Foam
 

·
Registered
Joined
·
2,804 Posts
My receiver drier crapped itself and sent bits everywhere blocking the TX valve. Still worked but not its usual COLD.
 
1 - 12 of 12 Posts
Top