Patrol 4x4 - Nissan Patrol Forum banner

1 - 17 of 17 Posts

·
Registered
Nissan patrol Gu Dx ute
Joined
·
127 Posts
Discussion Starter · #1 ·
hey guys
recently my airconditioning has stoped working, ive tryed chaging the fuse but with no luck of fixing the problem. When you turn it on it just pumps air from the fan, although the revs do not change at all, its as tho its not even kicking in. Not sure wether this means its somthing wrong with the wiring then, or if its re gassing thats needed. But i would think that it wouldnt be regassing, cause other wise the revs would change, although nothing appears to be happining. But then on the other hand when u presse the airconditioning button or the recycling air button they still light up, if it was an electrical problem wouldnt these not light up? im kinda stuck on what to check next, i would appreciate all suggestions. so please if you have any idea please let me know.

regards jesse
 

·
Registered
nissan
Joined
·
502 Posts
your pump hasnt seized up and flicked the belt off has it?
 

·
Registered
Joined
·
3,612 Posts
1 Turn your fan onto 1 and then press the aircon button, if you hear a click that means the aircon clutch is engaging , if no click then the clutch is not engaging.
2 Your engine revs should change slightly when the aircon kicks in.
 

·
Registered
nissan
Joined
·
729 Posts
If it was mine I'd turn aircond on and ignition on (don't start car) and see if there is power at the aircond clutch.
Check fuses first though.
 

·
Registered
Nissan patrol Gu Dx ute
Joined
·
127 Posts
Discussion Starter · #5 ·
yer ive tryed this and there is no click and the revs dont change at all.
 

·
Registered
Joined
·
116 Posts
could be leaking gas therefore with no gas in the system the AC will not cut in, take it to AC bloke and get it checked for leaks.
 

·
Registered
Nissan patrol Gu Dx ute
Joined
·
127 Posts
Discussion Starter · #7 ·
so iff it needs regassing it wont cut in at all?
 

·
Registered
Joined
·
116 Posts
if there is no gas in the system the AC compresser will not cut in, therefore ther is most likely to be a leak in the system allowing the gas to escape.
 

·
Registered
Nissan patrol Gu Dx ute
Joined
·
127 Posts
Discussion Starter · #9 ·
awsome ill try that get it cheacked for leaks and get it regassed.
 

·
Registered
Joined
·
35 Posts
check the fuseable link for the condencer fan

thats why my didnt work eg not kicking the the clutch pully


but i was low on gas too i still have to replace the fan
 

·
Registered
Joined
·
101 Posts
I have recently got mine regassed and yes it was kicking in before the regassing but it just wasnt blowing cold air and then i got it regassed and now the pump doesnt kick in at all.
 

·
Registered
Nissan patrol Gu Dx ute
Joined
·
127 Posts
Discussion Starter · #12 ·
yer cause the clutch doesnt even engage there is no click from the aircon when u turn it on. just blows air.
 

·
Registered
Joined
·
101 Posts
I have searched hi and low on the car and all fuses are fine and all fuse able links are good too, I have also checked relays and everything there is perfect.

It was regassed about a month ago and it hasnt worked since. I did manage to find the wires on the receiver dryer werent connected and cleaned terminals and put back together and still nothing.

Whats the point of having air con if it doesnt work and i have been quoted $1500 for a new compressor but something is telling me that its not that.
 

·
Banned
Joined
·
2,050 Posts
Hi,

If it was regassed there is / was a leak. The compressor is the most likely spot, as it has moving parts and seals. The switch on the receiver / dryer is there because running the compressor with low gas will damage it.

Regards B M
 

·
Registered
Joined
·
3,195 Posts
if you pull the 2 wires off the top of the receiver dryer(i think its called) that is the switch that wont allow the pump to turn on if there is no gas so the pump wont seize. join them together with the car off, start the car with aircon off. turn the aircon on and if it engages with the wires bridged then you know you have no gas or the switch is faulty. if it still doesnt engage with the wires bridged then id be looking at clutch or wiring
 

·
Registered
Joined
·
3,195 Posts
oh and if it does engage dont keep running it with it bridged because if it has no gas youll **** the pump. there are little refill valves on the aircon pipes,you can push a screwdriver in there quickly to see if gas squirts out, if there is gas then maybe a rooted switch
 

·
Registered
nissan
Joined
·
4,831 Posts
If the wires were off the pressure switch is the clutch coil wire connected?????
Also if wires left off sounds a bit of a dodgy shop you took it to

you can do the test Oilrig suggested with out the engine running just have ignition on

Just brough anew compressor Sanden SD7h15 for a mates header, it will fit a patrol, cost just under $400 from coventrys should only take an hour to fit then test and gas makes the $1500 sound like a rip off, new clutch coil around $180 and a couple hours to replace
 
1 - 17 of 17 Posts
Top