Patrol 4x4 - Nissan Patrol Forum banner

1 - 13 of 13 Posts

·
Registered
nissangu
Joined
·
5 Posts
Discussion Starter · #1 ·
hi all im runen a 98 4.5 auto, on steep hills when it comes under load in low range and with the auto in low it wont rev over 2000rpm right boot hard into the floor even if traction is broken it just sits there spinning at 2000rpm . iv had this problem since i got the truck 18months ago ,the 4.5 give up the ghost 2 months ago so i fitted a 5ltr ss comodore v8 now it goes like a dog shot in the arse on the road but still wont pull over 2000rpm on steep hills dose anyone no if theres sum sensor on the auto or tcu that wont let it rev or has the auto had the dick ??? my mate has a 96 v6 auto pathfinder and when it looses traction on a hill you dont wanna be standen behind it with rocks and **** flying , it will rev to red line no problems this is wot i expected from the patrol even more so with the v8 fitted . iv asked all the mechanics and auto blokes around my area and they look at me as if im the idiot . (well maybe i am ) anyone having or had this problem or no the solution ??????
 

·
Registered
nissan
Joined
·
336 Posts
What does it sound like when hitting 2000rpm, is it a miss fire, cutting out, or just hits a wall and can't rev anymore?
Steep hill, fuel pressure ok? Not starving for fuel?
What would happen if you were to stop on a steep hill, select neutral, and free rev it?
 

·
Patrol 2.8 TD
nissan patrol
Joined
·
1,640 Posts
umm is your tacho stuffed?

does it sound like it's doing over 2000 rpm or not?
 

·
Registered
nissangu
Joined
·
5 Posts
Discussion Starter · #4 ·
the engine is running fine it just wont get the power through the auto . i dont think its a engine issue because its done it with both engines , its like its in high range instead of low
 

·
ZD30 Out - L77 In!
nissan patrol
Joined
·
3,346 Posts
If your problem was mechanical within the transmission, I would suspect that it would be noisy and your auto fluid would burn and discolour very quickly. Even if the TCU was going into alarm, it would be holding engine revs through the ECU, so that shouldn’t happen with the V8. You may be able to check for a fault code on the TCU although I can’t see how it could affect engine rpm unless it’s integrated with the ECU. Will it rev higher in neutral or park?
Are you getting full throttle when the pedal is on the floor?
 

·
Registered
nissangu
Joined
·
5 Posts
Discussion Starter · #6 ·
the engine will rev to red line any other time on road in mud on flat goen in the bush ,i have a camper weighing a ton plus and pulls it perfect , the engine is running perfect no probs there at all point its nose up hill and there the problem is , its like its in 3rd gear instead of 1st its done it with 2 engines both on petrol and gas it think its safe to say its a auto issue not the engine
 

·
Registered
nissan
Joined
·
4,992 Posts
It sounds like you've reached the torque convertor stall speed but it shouldn't do it if you're really in low range.
I assume you know that just putting it into 4wd doesn't automatically put it in low range.
Is it maybe in 2nd gear 'Hold' as well?
 

·
Registered
Joined
·
91 Posts
Hiya, as above....this may be a dumb statement but have you checked the button on the console below the hand brake, this will start the car in 2nd and feels like [email protected].


my 2 bobs worth.

Col
 

·
Registered
nissan
Joined
·
399 Posts
Also check the fuse for the auto, if its blown, it can cause the same issue.

I just bought a GQ and the seller mentioned that the Auto wont select 1st gear at all, but if i manually select it, it will work no worries.
a 0.25c fuse had blown which had essentially put the vehicle into 'limp home mode'.
 

·
Registered
nissangu
Joined
·
5 Posts
Discussion Starter · #10 ·
After 18 years of 4wden i realise low range is different to high range ,iv tryed it in hold mode ,power mode and normal mode iv also put the shifter in low then took the linkage off to see if its adjusted rite and all is good . if i manualy select 1st take off then select 2nd then 3rd then od its all good . the stall on the converter is around 1800rpm witch the 4.5 would rev to on a hill the 5ltr will go to around 2000 to2200 rpm because of more power ,hills iv done in manual trucks half throttle i now need full throttle (and leaning forward) .. the fuse i havent looked at, very good point i will be straight onto that in the mornen
 

·
Registered
nissan
Joined
·
24 Posts
It sounds like you need to top your gearbox oil up. i was having some what of a similar issue on 3lt auto. would drive all right but on hills especially in reverse it would basically stop moving and the motor would rev to buggery before anything happened. turned out to be the Trans fluid was really low and that who ever did the change before i got the car didn't use the correct fluid for the auto. so i am in the process of slowly changing the oil over a few changes because not all the fluid comes out when you drain it. and filling through the dipstick hole is pretty crappy job
 

·
Registered
nissan patrol
Joined
·
86 Posts
Buzz,
The quick way to flush the auto is to disconnect the radiator line for the tranny and start the car. The gearbox pump will push over 90 % of the fluid out this way.
 
1 - 13 of 13 Posts
Top