Patrol 4x4 - Nissan Patrol Forum banner

1 - 3 of 3 Posts

·
Registered
nissan
Joined
·
27 Posts
Discussion Starter #1
Hey guys,

Have a 4.8SA which has had an intermittent fault in that it gets stuck in 2nd gear. The AT light on the dash flashes about 10 times when this happens. Sometimes it just clears.

Had it in at a trans shop the last couple of days. They've changed the solenoid - but then another 3 error codes (need to find out what they are!) showed up.

They've traced the loom and doesn't seem to have a problem - and hooked it up to a couple of computers but couldn't solve it.

Anyone had this kind of problem before?
Cheers.
 

·
Registered
NISSAN GU PATROL
Joined
·
694 Posts
Did it go into limp mode ?
Or just got stuck in second.

If its going into limp mode it could be something else totaly trigering that besides for just a faulty solenoid.
 

·
Registered
nissan
Joined
·
27 Posts
Discussion Starter #3
Sorry not been on for a while.

Took it to an auto electrician who couldn't find any faults in the wiring. Cleared the error codes and was all good for a about a month or so...until Wednesday.

Switched on to leave for work and was stuck in 3rd. Luckily there's enough power to move off from standstill LOL.

Was travelling at 100k's or so...and it puts it into 1st! Had to coast until slow enough to accelerate again to 70 or so then coast again. Had to do this for another 15k's or so and then it worked!

Moving the Gear Lever across from Auto to Manual would only show D on the dash.

Makes driving a little challenging to say the least.
 
1 - 3 of 3 Posts
Top