Patrol 4x4 - Nissan Patrol Forum banner

1 - 6 of 6 Posts

·
Registered
nissan
Joined
·
2 Posts
Discussion Starter #1
Hi All, New on this forum and it looks to have a good community.

I have had previous patrols, and have now brought an old one just for alittle bit of fun. Its a 2002 GU model, 3 litre engine with 3 speed auto ( plus Overdrive )

I have a vehicle manual in a CD form for a GR Europe patrol.

However I do have some issues with the automatic transmission.

1. When I put the vehicle auto stick to gear 2, no problem with that, but if I click t up to D it will not change into 3rd, I have to put it into neutral then back in D, then all good into 3rd.

2. The vehicle when in D changes into overdrive, that's OK, BUT it does not matter if the Overdrive button in on of off, it still changes into overdrive. I cannot get it out of overdrive except by hard acceleration ( kickback) or slowing down - then it does come out of O/D, the O/D light on the dash works when pushing O/D button on/off.

The automatic changes well between all gears. I have tried the manual for help, in the testing by changing through the gears - O/D button On / OFF, press accelerater etc, I have not code on the "sport"button just blank.

has anyone had this problem or can head me in the right direction.

Thanks
 

·
Registered
Nissan
Joined
·
84 Posts
Could be the computer playing up or something to do with a linkage somewhere or even the box itself , ours won't change into OD until the transmission is warm and the GQ sometimes does what's happening to yours when it's a very cold morning but when everything warms up operation is back to normal .
What's the condition of the trannie fluid like ? Is it burnt black or light red in colour ?
More questions than answers sorry .
 

·
Registered
nissan
Joined
·
2 Posts
Discussion Starter #3
Thanks,
The tranny oil is nice and red and smells good, the problem does not go away at anytime hot or cold. Yes maybe a computer problem, or the pnp switch?
It still drives very good through the gears up and down.
 

·
Registered
Nissan
Joined
·
84 Posts
It's basically the same box that's in the GQ I have and I know there are threads that help you fault find by using voltages .
 

·
Registered
Joined
·
452 Posts
Hi All, New on this forum and it looks to have a good community.

I have had previous patrols, and have now brought an old one just for alittle bit of fun. Its a 2002 GU model, 3 litre engine with 3 speed auto ( plus Overdrive )

I have a vehicle manual in a CD form for a GR Europe patrol.

However I do have some issues with the automatic transmission.

1. When I put the vehicle auto stick to gear 2, no problem with that, but if I click t up to D it will not change into 3rd, I have to put it into neutral then back in D, then all good into 3rd.

2. The vehicle when in D changes into overdrive, that's OK, BUT it does not matter if the Overdrive button in on of off, it still changes into overdrive. I cannot get it out of overdrive except by hard acceleration ( kickback) or slowing down - then it does come out of O/D, the O/D light on the dash works when pushing O/D button on/off.

The automatic changes well between all gears. I have tried the manual for help, in the testing by changing through the gears - O/D button On / OFF, press accelerater etc, I have not code on the "sport"button just blank.

has anyone had this problem or can head me in the right direction.

Thanks
for point 2)...
Have a look in the manual at the wiring diagram for the OD switch. From memory to check the switch function isn't that hard;
One side of the switch should have 12v negative feeding into it coming from the TCU. On the other side of the switch it should have either nothing or 12v negative depending on the switch position.

It sounds like you have a few issues - I would check for a good earth as a start. Second would be to change the fluid anyway to make sure it is the right specification unless you know for sure it is Dex 3 compatible.
 

·
Registered
Joined
·
3 Posts
Did you find a resolution for this problem? Mates GQ is currently having the same issue so looking to help him out.

Thanks!
 
1 - 6 of 6 Posts
Top