Patrol 4x4 - Nissan Patrol Forum banner

1 - 9 of 9 Posts

·
builder not a buyer!
nissan
Joined
·
2,702 Posts
Discussion Starter · #1 ·
G'day guys. Just installed 3" exhaust no muffler or cat onto my zd30. It's an auto plus egr blocked on the bottom side of the valve.

Now I have noticed that my boost gauge rises through to 14psi (max) as normal but then suddenly drops back down to 10psi then rises to 12psi.

Any ideas or thoughts of what this could be?

Thanks for your help
cheers
 

·
builder not a buyer!
nissan
Joined
·
2,702 Posts
Discussion Starter · #2 ·
My thinkin could be an egr problem. Even though it's blocked I could be losing that 3-4psi back down into the valve?

Haven't turned my needle valve back yet, so ill block top side of egr and turn needle valve down and report back

cheers
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
48,554 Posts
My thinkin could be an egr problem. Even though it's blocked I could be losing that 3-4psi back down into the valve?

Haven't turned my needle valve back yet, so ill block top side of egr and turn needle valve down and report back

cheers
Chuckles, not sure the EGR block position is the problem mate, mine is blocked way down at the valve and it doesn't do that.
My experience so far is that every time I have made a significant change to the running gear I have needed to re adjust the NADS components.
 

·
Banned
nissan
Joined
·
261 Posts
G'day guys. Just installed 3" exhaust no muffler or cat onto my zd30. It's an auto plus egr blocked on the bottom side of the valve.

Now I have noticed that my boost gauge rises through to 14psi (max) as normal but then suddenly drops back down to 10psi then rises to 12psi.

Any ideas or thoughts of what this could be?

Thanks for your help
cheers
Hi chuckles, I assume you have a dawes valve set up? IF so, could it not simply be the dynamics of that valve limiting the boost as it opens, dropping the pressure down under the set and then rising up to a level under the pressure it opens at. this is exactly what mine does as it works.
sounds like this has changed with an exhaust upgrade, which could be that the flow of exhaust has increased the rate of knots at which the pressure to the dawes arrives at max. This could also increase I guess, the dawes "bounce" effect I have described above. Of course if you dont have a dawes valve, this is all wrong...
By the way, how much extra go has the exhaust given you?? would you do it again?
 

·
builder not a buyer!
nissan
Joined
·
2,702 Posts
Discussion Starter · #5 ·
Cheers geeyoutoo for the reply I'll do sone playing around.

Cheers skamme. Yeah do have the Dawes set for max of 14psi as I found I was always going into limp even though I had the needle turned right down, I might go back to the original plan of 18psi max and turn the needle down. Def do the exhaust again, heaps of getup. No real life testing for fuel economy or Performance offroad. The exhaust has seemed to have found more power after 3000 rpm which is nice too.

Cheers guys, I'll report back after doing some tinkering
 

·
Currently in PAD rehab
Joined
·
18,404 Posts
Keen to hear how you go Chuckles, mine does a similar thing.

Ive been told several times to wind my vnt screw down half a turn to slow down the spool rate but everytime i look down there to do it all the pipes and stuff going everywhere puts me off. I opened my needle valve a click or so and it seems to have slowed it down, maybe give this a try?
 

·
Registered
Nissan CRD
Joined
·
893 Posts
They would have taken the intercooler off to fit the dump pipe. Sounds like one of the clamps on the rubber intercooler connector pipes might be leaking.
 

·
Registered
nissan patrol 2007 ti
Joined
·
55 Posts
have to agree with Brad I had Scotts 3 inch fitted then found leaking intercooler pipe week later the clamp hadn't been tightened, also split in vac hose to boost control so moral is to check after work done
 

·
builder not a buyer!
nissan
Joined
·
2,702 Posts
Discussion Starter · #9 ·
Cheers for the replies guys.

Have wound boost upto 16psi and turned the spool rate down but still dropping about 3psi. Patrol is going in Monday to have a muffler fitted as I'm not real happy with the idle note or the note anything under 14psi.

Will report back and see if the added back pressure will cure the problem.

Cheers
 
1 - 9 of 9 Posts
Top