Patrol 4x4 - Nissan Patrol Forum banner

1 - 10 of 10 Posts

·
Registered
nissan
Joined
·
18 Posts
Discussion Starter #1
Need help with 2000 3lt boost pressure. Recently fitted tunit chip and 2 1/2 exhaust , went great for about 1000ks but all of a sudden can`t get boost to go over 10psi. Played with settings on chip (eg 1 to 9) only difference was a sh*t load of black smoke, no problem with fuel. Removed all intake hoses and pipes down to inlet manifold no cracks blockages and have a catch can so fairly clean. put it back together no change. Checked all vaccum lines and all were as per manual pressure. Checked all sensors with multimeter as per manual all ok. No engine check light on and no fault codes. Removed a cleaned egr valve and blocked them off when reinstalled. Boost no peaking at about 20psi and seemed to be going into limp mode so backed out the vnt screw and now peak boost is about 12psi but still seems to be going into limp mode. As I am driving down the road sitting on 100ks boost pressure will sit on about 5psi, drive for about 20sec and you have nothing at the accellerator until you lift your foot and put it down again, do not know what else to check or replace, need help. Will be getting a dawes valve asap but not confident that this will fix my problem.:headwall:
 

·
Registered
nissan
Joined
·
35 Posts
ABJ
1. Try a known good maf sensor as for i have seen plenty of them test OK look OK but when in working conditions they just don't work also check your pnp switch these pair cause plenty of dramas

2. i would remove/disabel the chip for testing purposes and see if this has a bearing on what's happening

3. check your vacuum is it ok is it strong is the vacuum pump working properly all the time

4. Is the boost solonide working propley or is it having a moment under certain conditions as easy way to test it would be to t junction in near the turbo with a vacuum gauge and when and watch for change under varying conditions

5. falling all this check the spill valve in the injector pump i have had it where the spill valve jams say at 13 degrees 100 klmph cruising and once this happens it gives you the same feeling as a over boost situation the car will twitch/note change and you can then put your foot down and nothing will happen (until you remove you foot and press down again )all the other sensors are still working (eg) acc pedal 4.3 volts becuse you foot is flat remember the spill valve is affectively the fuel supply to the pump so with no fuel = no go

Defiantly start with basics check the earths to the engine, maf , pnp the pnp switch conrtols timing ,fuel supply etc so check it vary carefully and if in doubt get hold of a test unit also check, fuel condition , and probably do a bubble test and just work from there remember if it turns out to be a spill valve its in the injector pump and this now becomes costly so check every thing
hope this help
 

·
Registered
nissan
Joined
·
18 Posts
Discussion Starter #3
Chip has been left disconnected.
A new maf has been used.
PNP?
Vacuum is spot on at the pump,solenoid and turbo as I also have nissan work ute I compared all this to.
Is there any way to test the pump without removing, the flat spot in the accelerator pedal wasn`t happening until i blocked off the egr system, should this be blocked after or befor the egr block?
Previous to blocking the egr it didn`t matter what I adjusted I could not get any more than 10psi boost, then after blocking egr started having all this other trouble.
 

·
Registered
nissan
Joined
·
35 Posts
ABJ
the pnp switch is the park neutral position switch on the side of the gear box as i said this little devil plays a major part in the way you car runs if its reading that its neutral while you are in gear you will better-off off getting out and walking because of the effects it will have on timming, fuel ,boost ,

I put my blocking plates on the right hand side down were the alloy pipe goes into the egr i were the 2+ 14 mm bolts are so it will then be just behind the first pipe this is were i have always put them and they have never given me any trouble

to check the fuel pump you will need a scan tool or have removed stripped and repaired but the minute they stripp it you are up for big bucks as for the little ecu on top is a one time use type sucker
by using a scan tool you will be abel to see certain inputs like the spill valve to see if its advancing or not .

here is another idear that i just thought of how often is your car serviced how many k and how often do you have your air cleaner replaced i have started seeing alot of turbos looking and visually working ok eg little vnt arm working and looking ok but internally the little legs that catch the exhaust gases are stuck, broken ,or the main shaft in the turbo is starting to bind up which is causing problems like lack of power not boosting up propley or first thing in the morning for 2-5 ks not having boost at all
i have seen this issue with turbos with between 30 -90ks on the clocks so its very possible but i would look at the switch first (pnp) because you can do that even if you pinch it off your work ute and work from there
hope this helps
 

·
Registered
nissan
Joined
·
18 Posts
Discussion Starter #6
The cat was replaced with the rest of the exhaust it has a high flow cat and anyone has seen inside one of those there is not alot to them, has the honey comb look but just a bit os stainless.
Oil, filter and air filter get changed every 5000ks. Fuel every 10000 to 15000ks.
Have had bubbles in fuel lines before when firts got it, ended up being cracked fuel filter housing. Totally different feel to that. I will check pnp and swap if have to. Work ute is crd but swapped all sensors i could as some are different eg maf.
Did think about turbo and the next thing I was going to do was try different turbo as you said the little arm feels the same as work ute and had intake end of turbo off, no axial or horizontal movement but it didn`t seem to be as free as I thought it should be, you can spin with fingers but maybe does 1 to 1 1/2 turns and stops I thought it may have free wheeled a little easier. There is a deisel injector service mob in town I`ll give them a ring if pnp and turbo check out ok, thanx for the ideas keepem coming.
 

·
Registered
nissan
Joined
·
19 Posts
is the pnp only on autos or manuals as well?
 

·
Registered
nissan
Joined
·
18 Posts
Discussion Starter #9
been a while to get back to you,work, kids, handbrake. Tested all the things in the threads from people and ordered a new maf as the one that I had bought is out of a different model and after looking into it with a mechanic from a once was nissan dealership found out that there are seven yes seven different maf sensors for different models, waiting for it to turn up but am pretty confident that the maf is the problem, when it arrives and all is good, will have readjust the vnt(been playing with it) and let you all know.
 

·
Registered
nissan patrol
Joined
·
326 Posts
Have heard that after improvements you need to disconect battery for 20 min to rest ECU
 
1 - 10 of 10 Posts
Top