Patrol 4x4 - Nissan Patrol Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all
New here and im just wondering if anyone would possibly know how to access the fuel pump for a 2002 gu series 3 the the car has been modified to a ls1 so running 98 however I've followed the fuel line from the reg(which has a guage mounted on it showing 0psi) all the way to the rear of the car and it looks like its and in tank pump I'm wondering if it would be better going in through the car or to drop the tank itself any help is greatly appreciated cheers.
 

·
just a good guy.
2009 gu crd ute
Joined
·
8,025 Posts
Under the carpet in the rear is an access panel for the fuel pump in tank top. Also depends on whether is original tank or was it converted from diesel. And welcome to the forum hope to hear if you sort it out and not just a one post wonder.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Cheers guz it was right there,
Only had problems with taking apart my rear draw setup hahaha new pumps ordered just waiting on arrival
 

·
Administrator
GUII ZD30DI Wgn
Joined
·
43,893 Posts
Cheers guz it was right there,
Only had problems with taking apart my rear draw setup hahaha new pumps ordered just waiting on arrival
Yes getting at that access with draws is a pain in the arse, have been wanting to do the tank capacity increase for years and that is what has been holding me back, one day soon, I've got a rattle in the sl8de so I need to pull the top off anyway!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Their seems to be a problem with the fuel system electrical controls after replacing the faulty pump I noticed my sub tank light would stay on constant and when I tried to engage the sub nothing happened apparently that means theres a fault in the electrics if this is so how do I fix it?
 

·
Administrator
GUII ZD30DI Wgn
Joined
·
43,893 Posts
Their seems to be a problem with the fuel system electrical controls after replacing the faulty pump I noticed my sub tank light would stay on constant and when I tried to engage the sub nothing happened apparently that means theres a fault in the electrics if this is so how do I fix it?
Is it all running through an ECU of some kind? You may need to do an ECU reset for it to accept.
 

·
Registered
nissan
Joined
·
3,942 Posts
The sub tank should still be operating independently via it's own controller which should be behind the dash below the radio. Dropping the earth off for a while usually clears the sub tank error but it's not necessarily permanent. Bad earths often affect the sub tank operation as well as other intermittent and regular faults. The "solution/help" is to clean all your earths but more importantly add a decent earth from the body to the chassis. Have a read, best place is under the tunnel back of the box as there are suitable bolts/holes ready to use.

This may or may not also help your other pump issues. If your main pump is still not working have you stared checking you have voltage to it and how much etc. Don't assume that whoever did the conversion actually did a sound job of it. (Unless it was you in which case sorry to offend unless i turns out you deserve it ;) )
 
1 - 7 of 7 Posts
Top