Patrol 4x4 - Nissan Patrol Forum banner
21 - 25 of 25 Posts

·
Registered
02 GU ZD30
Joined
·
10 Posts
Discussion Starter · #21 ·
I've had it leak from the inlet/outlet originally but that has been sealed up for a few weeks now. The bottom has now become wet with diesel see photo. I'll have a close look for a stamp next time I'm in the shed. There were no stickers on it like yours had.

Automotive tire Motor vehicle Wood Automotive wheel system Gas
 

·
Registered
2003 ZD30 Patrol
Joined
·
227 Posts
I've had it leak from the inlet/outlet originally but that has been sealed up for a few weeks now. The bottom has now become wet with diesel see photo. I'll have a close look for a stamp next time I'm in the shed. There were no stickers on it like yours had.

View attachment 542147
Any progress on this one yet? Very curious as to what the cause is.
 

·
Registered
02 GU ZD30
Joined
·
10 Posts
Discussion Starter · #23 · (Edited)
@RAGGQ The company just told me I have to send it back for testing if its faulty but it was dry when I just looked at it so not sure where the diesel came from... maybe the seals around the terminals are a bit dodgy when you tighten/fiddle with the terminals it leaks slightly. @geeyoutoo no markings on the pump body at all that I can see as to country of manufacture... unless its on top somewhere that I cant see with it installed.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
52,510 Posts
Hmmm! that is strange and interesting, I would be sending it back just in case.
 

·
Registered
2003 ZD30 Patrol
Joined
·
227 Posts
@RAGGQ The company just told me I have to send it back for testing if its faulty but it was dry when I just looked at it so not sure where the diesel came from... maybe the seals around the terminals are a bit dodgy when you tighten/fiddle with the terminals it leaks slightly. @geeyoutoo no markings on the pump body at all that I can see as to country of manufacture... unless its on top somewhere that I cant see with it installed.
Definitely send it back and change it over for a newy.
Hopefully you can get an American one. I’ve got a Chinese one and had no troubles with it. Maybe it’s a Wednesday model 😊
Just a long shot here but has your bypass jammed shut or making fuel flow the wrong way causing some sort of blockage? If the vanes stop in the wrong spot in the pump it may not flow through
 
21 - 25 of 25 Posts
Top