Patrol 4x4 - Nissan Patrol Forum banner

1 - 12 of 12 Posts

·
Registered
nissan
Joined
·
323 Posts
Discussion Starter #1
this light started flickering today and got more constant to the point were its just on all the time now. checked all fluids and sensors cant find anything wrong engine oil was below the low mark topped up. but did not turn light of check brake fluid sensor all good.
im thinking it may be a wiring problem was wondering if anyone know what this symbol is refering too.

any help would be great or if someone can look in there owners manual for a 97gqtd42 and see what is says in there (hopefully not just take it to a dealership) hahah

Cheers Chris
 

Attachments

·
Registered
nissan patrol gq
Joined
·
284 Posts
thats the water in fuel warnign light, check ur fuel filter, maybe drain the fuel filter and re bleed it, if same problem, the water in fuel sensor is rooted or, u still have water in your fuel!
 

·
The nutty professor
Joined
·
8,299 Posts
^^ what he said, there should be a tap on the bottom of the fuel filter , open it up and drain some fuel out, or water , seems as you have picked up some water in the fuel somewhere
 

·
Registered
nissan
Joined
·
323 Posts
Discussion Starter #4
thanks guys. you were right. i found out the hard way though by using multi meter and tracing the wires at the back of my dash. found the wire to be shorting to earth started pulling dash apart to find it had rubbed through on firewall. so easy fix and now its all good.
but thanks for the help.

now that i know it works i might acually hook it up cuz previous owner had left it off.
thanks again
 

·
Registered
nissan
Joined
·
511 Posts
Yeah mine came on the other day, took it at face value, but haven't got round to checking it out. Wouldn't have thought about the shorting possibility!

Can someone clarify the procedure

Is it recomended to change the filter as it has had water in it?

cheers Greg
 

·
"Remember, you're unique... just like everyone els
nissan patrol
Joined
·
1,593 Posts
Is it recomended to change the filter as it has had water in it?

cheers Greg
I'd say a big yes to changing the filter at a minimum.

If you've had water that far up the line I'd seriously consider draining the tank out too. But depends if you know you've had really bad fuel recently or just haven't changed the filter in a while. If it's the later the water has probably built up over a while and the tank should be ok.

Filters are cheap engines aren't.
 

·
Registered
nissan
Joined
·
511 Posts
I'd say a big yes to changing the filter at a minimum.

If you've had water that far up the line I'd seriously consider draining the tank out too. But depends if you know you've had really bad fuel recently or just haven't changed the filter in a while. If it's the later the water has probably built up over a while and the tank should be ok.

Filters are cheap engines aren't.
Thanks you've got me motivated, i'll do it this arvo.
On draining the tank is there such a thing as a drain plug or is it complete removal and go in through the top?
 

·
Registered
nissan
Joined
·
323 Posts
Discussion Starter #8
Ok well i think i spoke to soon when i said i fixed the problem went for a drive today light came back on and also noticed the brake warning light coming on also, so yet again checked all sensor conections are ok and yeah they seem good pulled dash back out its all good. this time got my wiring diagram out and found out that connecting these two lights there is a 12v feed direct from the alternator that also goes to your alternator warning light also. so checked straight out of back of alternator 12v coming out but from there to my dash its gone. but my alt light goes out on start up so maybe a little more searching behind dash should find the problem, there must be a splice behind there somewhere. but its raining now and cuz im too poor to own a shed i dont wanna work in the rain so just thought id give you guys the update just incase anyone ever has this problem. but hopefully for them they dont cuz with out wiring diagram and a bit of knowledge with a multimeter this wud defianetly be a auto electrics jobs. and from my history with them they sure know how to charge hahah, well rain is easing so think ill get back into it.

Cheers Chris
 

·
"Remember, you're unique... just like everyone els
nissan patrol
Joined
·
1,593 Posts
Thanks you've got me motivated, i'll do it this arvo.
On draining the tank is there such a thing as a drain plug or is it complete removal and go in through the top?
I'm pretty sure the only way into the tank is to drop it out. I know from fitting my long range secondary tank the lines can be a bugger to get to, a body lift will make it 10 times easier though.

If you've got water in there though it'll be worth the time and effort, just to be sure.
 

·
Registered
nissan
Joined
·
323 Posts
Discussion Starter #10
ok defianelty not a wiring issue, if i turn my key off for a minute or two light go out then after having ignition on for a while they both turn on like clock work. check all terminal with multimeter everything ok so there must be some kind of computer in these things other then just the two sensor in the brake resivior and water trap something else is turning these two lights on. can someone please have a look in there owners manual and see if it says anyhting about having both fuel sedimentor light and brake warning light on thanks. otherwise im stumped anyone heard of this before????????????????????????

Cheers Chris
 

·
Registered
nissan
Joined
·
511 Posts
I'm pretty sure the only way into the tank is to drop it out. I know from fitting my long range secondary tank the lines can be a bugger to get to, a body lift will make it 10 times easier though.

If you've got water in there though it'll be worth the time and effort, just to be sure.

Well that was a learning curve, had it demonstrated to me 5000k ago, but till now had never done it myself.

Made a point of collecting the drain off from the bottom of the filter and collected at least 100mls of water :eek:

I'll take a photo and learn how to post it on here.

I had been making a point of buying from new servos and a high volume one , and with the huge rain perhaps someones got a leaking tank :(

I bought a glass bottomed cav filter assembly which i'll set up before the genuine one which I can keep an eye on till I rip the fuel tank out and give it a clean.

Thanks for the help, much appreciated.
 

·
Registered
nissan
Joined
·
323 Posts
Discussion Starter #12
Ok well finally found the culprit traced everything back to a relay in the engine bay near the battery were all the relays are there is a big blue one there that was upside down and full of mud pulled it off ripped it apart nad there was that much crap in there that it was arcing out between terminals and turning the lights on cleaned it out lights out now took for long drive idnt come back on so finger crossed its fixed now for good and i have just learnt something else about my car. thats why it always pay to do things yourself so if it happens again i no where to look instead of just paying someone to look for me.

Cheers Chris
 
1 - 12 of 12 Posts
Top