Patrol 4x4 - Nissan Patrol Forum banner

1 - 7 of 7 Posts

·
Registered
nissan patrol
Joined
·
316 Posts
Discussion Starter #1
Hi guys, got the ECUtalk cable and running it on my laptop, have taken a log from a short trip (20km) for all to see....you will notice that the car is running quite hot adn gets to 110 degrees climbing up the shot hole canyon rd.

Couple of questions....if i have a faulty coolant sensor wouldnt the ecu and therefore ECUtalk read high? The temp gauge on the car got to 3/4 and this has been an ongoing problem with radiator been rodded, new radiator caps, new water pump and viscous coupling, two different thermostats and not using a thermostat, but it contiues to get hot. Doesnt loose water or boil.......


OK and other question is....what do the ECutalk sensors mean and what should their readings be?

Thanks again.



PS i had to delete alot of the log to fit it on here but if you want the whole thing i can email to you.....pm me....
 

Attachments

·
Registered
Joined
·
757 Posts
the ECU talk gets its temp reading from a different sensor (there are two water temp senors on the head) to your temp gauge so based on the fact you temp gauge it getting to 3/4 and the ecu talk is saying that there would be a fair chance that the number is correct. I would be quite worried if mine was running that hot.
To give you a guide my 2.8 runs at 85-87 (never been higher han 93) and when i plugged the unit into my 3 litre ute it never got above 82.
Without wanting to offend you is there any chance the radiator was not cleaned out correctly?
I just had a thought have you tried running with the gas switched off to see if you get lower engine temps. You might have too much gas going in your engine.
 

·
Registered
nissan patrol
Joined
·
316 Posts
Discussion Starter #3
Thanks for the info camo and yeah im seriously worried about the ongoing temp issue.

Ive not actually been running the gas for sometime but not a bad idea thanks.

Not sure about the radiator......i did have it pulled out by a local mechanic and sent some 300km down the road to get rodded out.....id hope they did a good job! They said it was only 10-15% blocked......

Are my MAF readings too high? 2.18v at idle??
 

·
Registered
nissan patrol 2.8td gu st
Joined
·
249 Posts
To give you a guide my 2.8 runs at 85-87 (never been higher han 93)

my 2.8gu has gone weirdo on me since ive rodded rad and changed stat it races to sit on 89-90 now, i havent had the chance to push it up a great big hill yet but before it sat on around town and motorway 84-89 but up a great big hill it pushed up to 99... stat that came out was 82c and that whats it was replaced with aswell...
 

·
Registered
nissan patrol
Joined
·
316 Posts
Discussion Starter #6
Helmsy...... Where did you get that pdf file from?

Wouldnt mind getting my hands on that!

Anyone else know what the other sensors are and what they should display?

Cheers
 
1 - 7 of 7 Posts
Top