Patrol 4x4 - Nissan Patrol Forum banner

1 - 7 of 7 Posts

·
Registered
nissan
Joined
·
78 Posts
Discussion Starter #1
Hi guys,
'03 GU ZD30 wagon , manual , non ABS.
Has anyone seen this, coming to work this morning sitting at lights, Sub Tank light , Park Brake light and Battery light all come on at the same time.
ECU talk voltage drops to 12.1 volt, ECU talk has no faults showing.
I assume Alternator has died, but has anyone seen these other lights come on and stay on?
I have shut down and restarted twice - lights still all stay on.

Thanks
 

·
Registered
nissan patrol gu4 wagon
Joined
·
392 Posts
Done any welding on the car with the battery still connected, that is what happened to me when I got some work done on the exhaust
 

·
Registered
nissan
Joined
·
2,588 Posts
alternator is shagged or the plug has come off the back check that first and put a multi meter directly on the post on the alternator will tell you straight up if its stuffed
 

·
Registered
nissan
Joined
·
78 Posts
Discussion Starter #6
Fixed

Thanks guys,
Mud ghecko was on the money. Bought new alternator from Auto spark and installed - all good.
 

·
Registered
nissan patrol gu
Joined
·
735 Posts
Thanks guys,
Mud ghecko was on the money. Bought new alternator from Auto spark and installed - all good.
Before buying a new alternator.......split the unit and check the brushes.

Have had cases where the GRP brush holders have warped and the brush gets held off the comm.
Freed up all works fine....

Keeps about 800 bucks in ya pocket...

My 2 bobs worth
 
1 - 7 of 7 Posts
Top