Patrol 4x4 - Nissan Patrol Forum banner

1 - 7 of 7 Posts

·
Registered
2005 3L Nissan Patrol
Joined
·
5 Posts
Discussion Starter #1
Hi.
Me vehicle has completely died whilst at idle.. dash gauges were going crazy before hand.. had the park brakes, sub tank and battery warning lights on a couple days prior..(also rained.. thinking a bit of water had switched these on) also had air blower motor malfunction.. did not blow any air at all.. replaced the resistor and cleaned and oiled up the spindle.. works whenever it feels like.. Had technicians hook up an after market stereo.. I'm guessing alternator is gone.. maybe due to the stereo.?? Maybe.. can not test alternator output as the vehicle does not start at all.. as well as not warning lights... HELP PLEASE.. :D
 

·
Registered
GQ Dual Cab. TD42Ti with fruit.
Joined
·
4,735 Posts
Have you checked your earths?????
 

·
Registered
2005 3L Nissan Patrol
Joined
·
5 Posts
Discussion Starter #3
Hey GQshayne,
I have got me car that start again, just had to replace a relay hidden under the dash above the fuse box.. sure I have a faulty alternator, the a/t oil temp lights and sub tank and hand brake lights are on in the dash.. am just curious on what would make the alternator to **** itself.. I do have installed an after market stereo..

Thanks for the response Brother.
 

·
Registered
GQ Dual Cab. TD42Ti with fruit.
Joined
·
4,735 Posts
The symptoms you describe are commonly associated with bad earths on the Patrol. Take off the earch straps between the battery, the body and the motor, and clean them up. Make sure all terminals are in good order. If you are unsure about this get an auto sparky to look at it.

Gauges playing up etc are an old fault that happens a lot. Earths are a problem when they are old. Check these before going any further.
 

·
Registered
2005 3L Nissan Patrol
Joined
·
5 Posts
Discussion Starter #7
Hey dkril,
I have just recently bought this rig.. does look pretty standard.. unsure
 
1 - 7 of 7 Posts
Top