Patrol 4x4 - Nissan Patrol Forum banner
1 - 10 of 10 Posts

·
Registered
nissan
Joined
·
19 Posts
Discussion Starter · #1 ·
Two weeks ago my engine light came on and car won't stay on, it would turn over stay on for 3secs and putter and turn off, how ever it is fine in gas. Woke up the following day and far was back to normal. Now its done it again, so drove it around on gas, it idles at 1700 which is a lot higher than normal, engine light still on.



Has anyone had this it got any idea what it could be
 

·
Registered
Joined
·
543 Posts
I get it your engine light is on. On what engine at a guess I would say tb45e.
You really need to read what you have typed to see if it all makes sense. If people can fully understand your problem they are very willing to help.
More info please
 

·
Registered
nissan
Joined
·
19 Posts
Discussion Starter · #3 ·
back off buddy, never heard of a gq havin a TB45e to start with dont no where ya got that from, all ya had to do is ask me what engine it is if thats what ya needed to no to help me, as for that i'v received great help from someone else of another forum with my same thread, this is one of my first "HELP QUESTION" from this forum, great way to make ppl feel welcome.
 

·
Registered
Joined
·
543 Posts
My apology I'm just old and senile
 

·
Registered
Joined
·
122 Posts
Mine done the same thing when i drowned the computer,would run on gas but not petrol..1
$1200 later problem fixed,computer didn't like being underwater...
 

·
Part of the furniture
nissan
Joined
·
4,563 Posts
i could be wrong,

but it sounds like you have a problem with a sensor,
my thoughts would either be air or fuel.


had the same sorta problem in a 2wd, poped in a new air flow sensor.. happy as larry!


if you got the funds, and you plan on keeping the GQ for a while to come..
fit up a ECUtalk module, it will tell you everything you need, or dont want to know.
[providing you have a TB42e and not a TB42]
 

·
Registered
nissan
Joined
·
19 Posts
Discussion Starter · #8 ·
yeh got a TB42e mate,
yeh was looking at those ecutalk, think i'll get one, i did a manual diagnosis and found to be the Engine temp sensor. so have changed that over and seems to be alright, which is good.

Would the best place to get the ecutalk from ebay
 

·
Registered
nissan
Joined
·
511 Posts
back off buddy, never heard of a gq havin a TB45e to start with dont no where ya got that from, all ya had to do is ask me what engine it is if thats what ya needed to no to help me, as for that i'v received great help from someone else of another forum with my same thread, this is one of my first "HELP QUESTION" from this forum, great way to make ppl feel welcome.

HOSTILE little ****er, this one.

If you read Murramans post he stated that he was guessing that it was a Tb45E!

If this is how you react for some extra info, no ones going to bother ITSSAM.

Show some character and apoligize
 
1 - 10 of 10 Posts
Top