Patrol 4x4 - Nissan Patrol Forum banner

1 - 9 of 9 Posts

·
Registered
Nissan
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi all, all the best for the new year. Quick question I have an 03 4.2tdi coil cab ute and today the engine light started flashing. It only seemed to do it once the engine was up around normal operating temp. Any ideas what it could be as I'm not really a fan of takin it to mechanics. Any help would be greatly appreciated. Thanks
 

·
Registered
Nissan
Joined
·
532 Posts
First thing is drop the fuel filter and put on a news one, generally it's water in the fuel but the only when warm is odd.
 

·
Registered
Nissan
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks I shall try that today. Would that make the engine rattle a little more than normal
 

·
Registered
Joined
·
451 Posts
Low on oil / filters blocking up...I'd be doing an oil change and filters pronto !
 

·
Registered
Nissan
Joined
·
5 Posts
Discussion Starter · #6 ·
Na hasn't worked do far. Changed fuel filter n no luck. Took it in to see what the code was and it said was something to do with fuel injection timing or something. Any of you had this come up. Cheers
 

·
Registered
nissan patrol
Joined
·
547 Posts
Na hasn't worked do far. Changed fuel filter n no luck. Took it in to see what the code was and it said was something to do with fuel injection timing or something. Any of you had this come up. Cheers
Gday,

Hmm yes just read your last post about it sounding rattly. I thought wonder if its timing/fuel delivery. Then there it was the INJ-TFB fault.

Yes unfortunately I am going through this at the moment, and after tomorrow Ill know if the IP is cactus beyond the point of saving.

You dont know anyone with ECUTalk do you that you can borrow...may not be your problem at all, but your welcome to read this--->

http://www.patrol4x4.com/forum/zd30-di-engine-3-litre-71/ecutalk-icv-%-129969/


And this----->
http://www.patrol4x4.com/forum/zd30-di-engine-3-litre-71/tank-pickup-lines-140746/

And this---->

http://www.patrol4x4.com/forum/zd30-di-engine-3-litre-71/icv%-survey-ecutalk-133625/

Can be caused from air amongst bad fuel and just plain old cactus.I really would like to know your ICV% as I am a believer in it being our lifeline to the IP health.


Woopsie! Sorry bud different beast I read 03 and assumed. Totally unfamiliar ground to me .Im just getting to learn this 3 tonne of electronic switch boards!.

cheers
 

·
Registered
Nissan
Joined
·
5 Posts
Discussion Starter · #8 ·
Apparently in 03 they started trying to make the 4.2 into an electronic engine. Finally got the fault code up and turns out to be a sensor on the back of the injector pump. I'll take it in and get the timing reset and hopefully that cures it.
Thanks all for your input. Will let you know the outcome
 

·
Registered
Nissan
Joined
·
5 Posts
Discussion Starter · #9 ·
Sorry for the long absence everyone but I finally have it sorted. Turns out the injector pump housing was about knackered. Got that back in and injectors done while it was apart n now running good as gold. Thanks for your patience everyone
 
1 - 9 of 9 Posts
Top