Patrol 4x4 - Nissan Patrol Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hello everyone I'm a long time lurker but my first post! Just wanted to say thanks for all the help the forum has provided

So I'm at a stump here

I recently done a front mount on my rd28 gq prior to that I was running 15-17psi of boost i changed over my gq manifold to a gu one and plumbed everything up but now I struggle to hit 10 psi ? I have turned the fuel up a notch but still no i have checked all the clamps and piping and I'm 99% sure i have no leaks it just won't go above 10 ?

Just wanted to know if anyone has had similar problems?

Thanks
 

·
Registered
nissan gq
Joined
·
1,851 Posts
hello everyone I'm a long time lurker but my first post! Just wanted to say thanks for all the help the forum has provided

So I'm at a stump here

I recently done a front mount on my rd28 gq prior to that I was running 15-17psi of boost i changed over my gq manifold to a gu one and plumbed everything up but now I struggle to hit 10 psi ? I have turned the fuel up a notch but still no i have checked all the clamps and piping and I'm 99% sure i have no leaks it just won't go above 10 ?

Just wanted to know if anyone has had similar problems?

Thanks
Tap in before and after cooler to check for loss there
 

·
Registered
nissan
Joined
·
6,730 Posts
Where is the boost that operates the waste gate fed from? .. before cooler or after cooler? .. or does the RD28 have an odd system like the ZD30?
 
1 - 5 of 5 Posts
Top