Patrol 4x4 - Nissan Patrol Forum banner

1 - 5 of 5 Posts

Registered
Joined
2 Posts
Discussion Starter #1
Hey Guys.

I have a big problem with my recently bought Patrol and run out of ideas with my mechanic. Car is using around 40 litres/ 100 km around the city or offroad and around 30/100 on highway. It's BOTH - petrol or LPG, the usage is the same with EACH fuels. I changed the spark plugs (no signs of too rich mix) No other indicates that something is wrong. The tappets run smoothly and my mechanic has no other ideas.

Any suggestions what to do will be highly appreciated. Thank you
 

Registered
Joined
4,638 Posts
MAF?? Airfilter?

What other things other than spark plugs have you looked at.
 

Registered
Joined
2 Posts
Discussion Starter #3
I did replace the air filter but didnt do the MAF. Nothing else was really done. I think my mechanic checked the lambda as well. I dont have much knowledge if it comes to cars unfortunatelly.... im pretty amazed in the difference since I learned that it should take max 25/ 100 so that s a huge difference
 

Registered
Joined
2 Posts
My old 4.5 GU used to use around 30/100, I changed everything. I adjusted the timing, adjusted the tappets, replaced the o2 sensor, cleaned the MAF, replaced the cat, replaced the plugs and leads, ran it on 98, ran it on 91, nothing really made a difference. Mine was an auto on 35s with 3.9 diff gears though.
 

Registered
nissan
Joined
254 Posts
I get about 380 to 400 ks out of a 90 litre gas tank, dont use petrol much but it does not seem to bad when i do. Apart from the lpg my 4.5 is factory. 20 to 24litres/ 100k would be a normal consumption in my opinion, regards Rod


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top