Patrol 4x4 - Nissan Patrol Forum banner

1 - 17 of 17 Posts

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #1
Doing glow plugs this weekend, any tips & tricks anyone can give me , attempting this for the first time so any advice welcome, Will be doing the glow plug timer also(.Zd30 DI)
 

·
Administrator
GUII ZD30DI Wgn
Joined
·
45,909 Posts
You will need a 12mm deep socket to start with, take care undoing the busbar nuts because the plastic casing cracks quite easily. I use a pair of long nose pliers in the grooves of the seals to twist them undone. Make sure the washers come out with the GP and smear a bit of grease on the new washers when you fit them on the GP, it helps make them stay thete as you fit them. I don't use a tension wrench much as I've developed a double click elbow over the years :), if you don't have one just do them up firm and evenly and go over them twice to make sure. Not a difficult job, just take your time.
 

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #3
Thanks for the tips, have purchased a deep 12mm socket and a 1/4 drive torque reach , a little high temp grease okay , can I put a little grease on glow plug thread or not needed?
 

·
Administrator
GUII ZD30DI Wgn
Joined
·
45,909 Posts
Thanks for the tips, have purchased a deep 12mm socket and a 1/4 drive torque reach , a little high temp grease okay , can I put a little grease on glow plug thread or not needed?
Yes you can, I do, but only a smear.
 

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #6
Update, halfway through ,all good so far . Throttle body nice and clean ( water meth has done a great job) intake manifold good also . More to come
 

Attachments

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #7
Looks like 3/4 glow plugs are in bad shape, some have bits missing on the tips. One was barely okay but replaced all of them.
 

Attachments

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #8
Can anyone tell if there’s any difference between these nuts for the glow plugs, the original factory ones look like they have the washer pressed in the nut(golden colour one right side in picture). The new silver ones on left side in picture have no washer at all , must be part of the nut ?
 

Attachments

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #9
All glow plugs in , seals no drama either, bus bar on with nuts (used the pressed washer factory OEM ones , still in good nick). LED for glow plug almost done .Timer will go in next week as I don’t need to use the patrol atm. Spent some time mucking around with water/meth nozzle on TB as it does fill loose for my liking. Will be changing back to the DO 4 .
 

Attachments

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #10
Started patrol late last night, glow plugs on for 5 minutes switched of at 34 degrees on ecutalk. Glow plug timer going in on weekend , busbar led works great, just added water/meth injection led on pillar pod also.
 

Attachments

  • Like
Reactions: geeyoutoo

·
Administrator
GUII ZD30DI Wgn
Joined
·
45,909 Posts
Exelent, have been thinking of moving my 3 wm signal LED from under dash up into pillar pod for some time, will be interesting to hear what you think when driving at night.
 

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #12
Exelent, have been thinking of moving my 3 wm signal LED from under dash up into pillar pod for some time, will be interesting to hear what you think when driving at night.
The glow plug isn’t an issue when driving at night,but the green water/meth injection led is not as bad considering it’s on continuously. Originally it was a red colour LED . The green colour is the way to go as the red felt a little harsh on the eyes 👀.
 

·
Administrator
GUII ZD30DI Wgn
Joined
·
45,909 Posts
Thanks, I have 3 LED, 1 red for low tank level and 2 green, 1 for when TB nozzle fires and the 2nd for when pre turbo fires, will give this more thought Steven
 

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #14
Agree,Once holes are made, there’s no turning back,
 

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #15
Update, installed power train glow plug timer on Saturday, works good ,just not seeing any power at busbar as no led coming on . Strange as everything worked perfect before timer install ?.. car starts no problems, glow plug lamp indicator on as normal but no LED now since power train . Will change glow plug relay once I source a new one. Is there any thing special required to do or just pull out apart from unplugging it . Have battery disconnected at the moment, Any suggestions welcome,
 

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #16
Update, still same ongoing issues , changed glow plug relay , checked relay for power train and wires including earths. Removed and checked glow plugs(new) for ohms (all good) and installed brand new LED plus wiring. Checked 100 amp fuse also , fuses in fuse box and ECM fuses all good there also. Still no power at buzz bar or LED coming on . Will check harness connector at buzz bar next,
 

·
Premium Member
Nissan patrol GU
Joined
·
256 Posts
Discussion Starter #17
Update, sent ECU back to ECPT to check transistors that grounds glow plug relay in the ECU, all good there also. Harness connector to buzzbar to check and some fuses in engine bay . Other than that running out of things to check.
 
1 - 17 of 17 Posts
Top