Patrol 4x4 - Nissan Patrol Forum banner

1 - 9 of 9 Posts

·
Registered
nissan patrol mq
Joined
·
30 Posts
Discussion Starter #1 (Edited)
hey just wandering if anyone would hav any ideas why the GQ wont idle? Just happend out of the blue. If you don't keep pumping accelerateror it cuts out and if you do keep it reving with pumping peddle it as if out of fuel .I put on new fuel filter. plenty of fuel comes out of hose into carby. dont yet hav a workshop manual, im only guessing its gotta be in the carby. its a 1993 3lt rb30. as soon as i switch the key to ignition and crank pump acc a few times leave foot off, it starts up for a half second then stops. its not stalling hmmm??? Any help appreciated.
Has any one fitted a different carby with success ? THis with out major rework to fit.
 

·
Registered
Joined
·
419 Posts
Personally I would rather not have any idol's in my patrol :)

I find it idle's better that way.

[/smartarse]

carby ? fuel pump workin ? Fuel filter blocked ?
 

·
Registered
nissan patrol mq
Joined
·
30 Posts
Discussion Starter #3
billy does suck :) i think its in the carby. filters ok, pumps ok and fuel lines. just gotta pull apart the carby, but im thirsty for a beer so ill do it tomorra. always tomorra
 

·
Premium Member
nissan
Joined
·
142 Posts
not sure but check ignition fuse had same problem with a mazda years ago would start but as soon as the key was turned from starting to on it would die.

Tim
 

·
Premium Member
nissan
Joined
·
2,256 Posts
It sounds like your ballast resistor might be the problem.

I would check this first.
 

·
Right Turn Clyde
nissan patrol
Joined
·
1,052 Posts
Does it have an idle solenoid ??, got power to it ?.
 

·
Registered
nissan/gq patrol
Joined
·
253 Posts
I am having the same problem. Runs perfect on gas. Will start up and run on petrol with me revving it but dies when i take my foot off the pedal. Can drive on petrol but when i slow down to turn a corner or stop it dies unless i keep revving it. I looked at the vaccum lines and there were two that were cactus so i cut off the ends and reconnected but issue is still not resolved. How do i check the ballast resistor is working? What esle could it be? Could the fuel pump be the issue?
 

·
Registered
Joined
·
2,713 Posts
I had a simalar issue with my tb42 - I put a carby kit though it - found found one of the ball bearing type plungers was gunking up.

ZThe rb30 & tb42 carbys use the same kit.

If you do put the kit though - pull the carby apart over a news paper - also take photos of the carby before you pull, aand whille you are pulling it apart. - will help when you assemble it
 
1 - 9 of 9 Posts
Top