Patrol 4x4 - Nissan Patrol Forum banner

1 - 20 of 21 Posts

·
Registered
nissan
Joined
·
20 Posts
Discussion Starter #1
I did a td42 conversion from a '99 gu patrol to a '03 patrol.
Issue No. 1
Subtank not working. Push button and nothing. I cant figure out wiring in service manual from model to model.
Im just shy of dropping tanks and changing loom there too. Main color wires match.
Issue no. 2
Drivers window not working but all others are. And central locking fine too.
Both issues since conversion.
Has anyone had similar issues when converting????
And how did you fix??
 

·
Premium Member
nissan
Joined
·
2,279 Posts
Did the 2003 model have 2 circuit breakers and 1 relay in the LHS passengers kick panel (inline with the bottom of the glovebox)? Is only 1 circuit breaker being used now?
 

·
Registered
nissan
Joined
·
20 Posts
Discussion Starter #3
I do believe it did. On the dash loom.
I changed all the dash loom the engine bay loom, loom from left kick panel to under car but not to tanks yet.
Dash itself is from '99 model.
 

·
Registered
nissan
Joined
·
812 Posts
that's yr problem

u swapped all wiring over but the door wiring might be slightly differnet

the best way is to keep orig loom and add the wiring for new engine

anyway start the the drivers window motor
2 wires one should get power and other should get ground when going up or down
then work your way back to the switch

Nissan service manual is a pain in the butt to navigate, u can tell some idiot behind a desk designed it
 

·
Registered
nissan
Joined
·
20 Posts
Discussion Starter #5
Reaaon why i started swapping was i started with engine loom then plugs were not right and extra on old. So i swapped out next. Then tried swapping out cluster and that was wrong at back, so next one. And so on.
 

·
Premium Member
nissan
Joined
·
2,279 Posts
Yeah the later models have an extra battery feed to the driver door window master switch. I'm guessing this is why the drivers door window isn't working.

I would just mount a circuit breaker, run a wire and connect it to the original drivers door harness.

Connector M22 is part of the dash loom that you changed. Pin 5N in connector M22 is the one I think is missing.

Connector D1 is the mate to M22 and it's the harness that runs through the drivers side door.

Have a look if there is a wire connected to pin 5N in connector M22 if not try connection power to it.
 

Attachments

·
Premium Member
nissan
Joined
·
2,279 Posts
The sub tank problem I'm not sure about. I can see a difference in the wiring diagrams between the two year models but I don't know if simply changing that will fix your problem.

I take it you are running the instrument cluster out of the 99 model?.

Which sub tank module? Do you have both? Do they have different part numbers on them?

How much effort do you want to put into this?
 

·
Registered
nissan
Joined
·
20 Posts
Discussion Starter #9
The module and switch were the first things i changed. There exactly the same.
I can see some differences in wiring on plugs outside car on chassis. But got to disconnect from main and sub tank to check.
Friday night and alcohol job.
 

·
Premium Member
nissan
Joined
·
2,279 Posts
The earlier one has a low fuel switch in the sub tank the later one doesn't. This is the only difference I can see at the moment.

The later model one just has this wire connected to earth.
 

·
Registered
nissan
Joined
·
20 Posts
Discussion Starter #11
Only wire different i can see in wiring is green with purple dot (old) to purple (new)
And yellow black line (old) to nothing, guess thats the earth one mentioned above.
 

·
Registered
nissan
Joined
·
20 Posts
Discussion Starter #13
might be blue trace but its dark and dirty so looks black and only yellow with trace there.
 

·
Premium Member
nissan
Joined
·
2,279 Posts
It sounds like we are referring to the same wire. It's not uncommon for the wiring diagram to be wrong as well.

If both fuel gauges are reading correctly I would try earthing that wire and see how that goes.

You may need to reset the sub tank module by either disconnecting it or disconnecting the battery.
 

·
Registered
nissan
Joined
·
20 Posts
Discussion Starter #18
1 Down. Sub sorted.
Ok so yellow black trace is low level light. Not connected to anything.
Yes there is a yellow blue trace and hooked upto earth works great. Thankyou Yendor
 

·
Premium Member
nissan
Joined
·
2,279 Posts
That was easier then I thought it was going to be.

Any luck with the window?
 

·
Registered
nissan
Joined
·
20 Posts
Discussion Starter #20
I didnt get a chance, had to do O/T last night so i didn't get the time.
Tonight ill try.
 
1 - 20 of 21 Posts
Top