Patrol 4x4 - Nissan Patrol Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1
Hi all got a problem i havent really looked into yet as i havent had time but i thought id see if anyone else has had it before.

Firstly its a GU TD42 with an after market Denco turbo kit on it, other extra's are Digital pyro 3mm probe Boost gauge and boost controller. I had the injector pump and injectors rebuilt 6months ago then got the engine tuned, they upped the pump and boost and it goes really well now.

Problem is if you ring its neck in a gear like 3rd it will boost up to 12-14psi and get to say 3500rpm and not rev past that but start to blow heaps of black smoke??? I mean heaps!!

Im thinking its the Turbo and that 3500rpm is its limit? although thats strange cause my ute is also a TD42 but with a factory Turbo and it will pull right through to governor which is set at around 4500rpm

Any ideas would be much appreciated.
 

·
The nutty professor
Joined
·
8,299 Posts
Sound to me like one of the inlet hoses has gone soft and is sucking itself in under high RPM conditions. Its very common when the black hoses get oil soaked over time.

what he said

sounds like lack of air , although on mine a lack of fuel does the same thing smoke wise but it still revs through to 5000 rpm
 

·
Registered
Joined
·
141 Posts
Discussion Starter #5
Sound to me like one of the inlet hoses has gone soft and is sucking itself in under high RPM conditions. Its very common when the black hoses get oil soaked over time.
Nice very valid point but mine has very short runs of black hose between the turbo intake and manifold which couldn't possibly colapse under suction and the only other part is the standard induction pipe from the snorkle to the DTS top mount air cleaner??? have these been known to colapse with suction?
 

·
Registered
Joined
·
111 Posts
Check your air filter. Then the fuel screen in the injector pump under the banjo bolt on the fuel supply line. Then try your fuel filter. See how that goes. How fast does it rev under no load?
 

·
Registered
Joined
·
141 Posts
Discussion Starter #7
Check your air filter. Then the fuel screen in the injector pump under the banjo bolt on the fuel supply line. Then try your fuel filter. See how that goes. How fast does it rev under no load?

Hi Shrek changed the air cleaner and fuel filter on last service worth a look at fuel screen but i reckon it will be fine injector pump only rebuilt a bit over six months ago and i did the job so cleanliness was a big priority and new filters before start up. Revs to governor with out load easily.
 
1 - 7 of 7 Posts
Top