Patrol 4x4 - Nissan Patrol Forum banner

1 - 8 of 8 Posts

·
Registered
nissan patrol gu
Joined
·
44 Posts
Discussion Starter · #1 ·
Hi all just wandering if anyone could shed some light on a issue im getting, My 01 4.2td water to air intercooled motor never overheats in fact it has never budges past the middle of C & H, but the other day towing my boat at 100 the temps kept climbing up. Could my heat exchange core off water to air be blocking my radiator, could it be my new xrox bar blocking air flow? :confused: Also got fuel problems using bugger all to get to work but when i hit highway it just drinks the tank between 360km to 400 km on the main tank at 100? is that normal. When injector pump was rebuilt i believe they left out some sort of plastic govenor that was and i quote "NOT NEEDED AND WON' USE ANY EXTRA FUEL"
 

·
The nutty professor
Joined
·
8,299 Posts
i would look for the small filter in the banjo bolt on the injector pump , this may be starting to block up restricting fuel flow , this can effect the pump timing causing it to retard a bit which can increase fuel consumption at higher revs , can also make the motor run hotter
 

·
Registered
nissan patrol gu
Joined
·
44 Posts
Discussion Starter · #3 ·
Thanks i will check this when i get home do you know if this will be in gregory manual?
 

·
The nutty professor
Joined
·
8,299 Posts
probly not, it is tricky and hard to find the tiny filter, from memory it is about 20mm down and there is a spring on the top holding it in place, although some motors dont have them fitted
 

·
Registered
nissan patrol gu
Joined
·
44 Posts
Discussion Starter · #5 ·
ok so how do i know if my injector pump originally had it. Me dad owns a mechanic store just havent had a chance to go visit him lately might go their today.
 

·
The nutty professor
Joined
·
8,299 Posts
thats the thing , it either will have it or it wont have it, it seems when they put the pumps together it was a lucky dip as to which ones got the filter and which ones didnt, but they do seem more common on the gu models, saying that , if you find a spring under the banjo bolt at the front of the injector pump then it is likely to have the filter aswell
 

·
Registered
Joined
·
387 Posts
Mine has the spring, but no filter. I assumed that either meant I couldn't hook the filter or the last owner had decided it was surplus, but my mechanic has since had a look and assures me that my setuPis common too!
 
1 - 8 of 8 Posts
Top