Patrol 4x4 - Nissan Patrol Forum banner

1 - 3 of 3 Posts

·
Registered
nissan
Joined
·
25 Posts
Discussion Starter · #1 ·
Hi Guys,
Long time reader first time poster,
I have only recently entered the 4x4 scene with the purchase of a 92 maverick carby Fed tb42 which needed some work such as swivel hubs, trailing arm bushes,valve stem seals, and a couple of other rubbers all of which I have done myself besides the stem seals thanks to the help of this forum it really is a great place with plenty of help and information.

So when my next little problem came up I thought I'd be best asking for some advice from the experienced people here before throwing money at the shop I hope someone can help.

So I had done the swivel hub seals and bearings on Saturday all went very well (a lot easier than it sounds) just time consuming anyway took it for a test drive parked in the driveway came out a hour or so later and noticed a small puddle of coolant sitting there under the diff,
Had a quick look underneath and it's leaking from a plate under the inlet manifold which has two hoses meeting a connector looking from above it would be directly below the carby,

So I left it till the next morning and tightened up the hoses started her up and noticed she was idling very low and trying not to stall auto choke seemed to do nothing so pulled on the manual for a bit and she picked revs up enough to run without choke but they are fluctuating by say 100revs or so from 550-450ish usually idles at 650-700 also picked up on a descent miss which is very noticeable and the leak is getting a bit worse but doesn't start leaking until shes up to operating temp.

It's really got me buggered what's going on as a coolant leak I wouldn't think would cause the engine to miss and play up as much as it is, it's not running hot or anything, also when I place my head near the intake I can hear a sound like a sort of gulping it's hard to explain but is coming from the head it's also blowing a lot more smoke than usual,

I haven't takin the manifold of yet but is it possible there could be a crack in the intake letting coolant into a cylinder causing it to miss and run like a pig ?

Before this she was running great besides the smoke on start up and a bit on decel carby has been rebuilt recently all leads and plugs also done although the oil passing the valve stems is getting the plugs fairly dirty.
Any suggestions advice would be greatly appreciated.
 

·
Registered
Joined
·
2,713 Posts
The leak could be from the coolant hoses - it is possibly to get to them from underneath - if you have VERY long arms - but the easier way is to pull the inlet manifold - you will need a new gasket - around $25 from bursons.

Burping could be the PCV valve - it sits in the inlet manifold and is connected to the the pipe coming up between the block and inlet manifold going to the rocker cover.

Missing etc can be caused by a vacuum leak, also loose carby - (grab the top of the carby and shake it - any movement. (there are 3 screws that are in the base of the carby that can come loose.
Try spraying some CRC or water around the inlet manifold - does the revs change

Missing can also be causeb by the leads / plugs
 

·
Registered
Joined
·
902 Posts
Pull all the plugs out and see if any of them are cleaner than the rest. This shows a coolant leak into that cylinder
 
1 - 3 of 3 Posts
Top