Patrol 4x4 - Nissan Patrol Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
Currently travelling Australia but my Nissan patrol has just lost all its power and can hardly set off.
In neutral it’s revs but bounces up the dial in a lumpy fashion.
blowing white smoke, with no warning lights on.
what could it be?
cheers

Narooma NSW
 

·
Registered
Joined
·
27 Posts
If there is no excess pressure in your radiator (check carefully after engine has cooled), and no mayonnaise like scum in it, then it could well be one or multiple bad injectors.

But check your fuel filter first. It may be clogged with crap and not flowing enough fuel, or could have water in it
 

·
After Monday and Tuesday, even the calender says W
06 Td42ti coil cab chassis
Joined
·
16,755 Posts
Hard to say with the limited info you have given..
Check oil and water for cross contamination,
Is it making any more noise than normal?
Is the engine shaking around at idle?
Try undoing oil filler cap while engine is at idle, will make a bit of a mess but if there is excess pressure there, you may have a holed piston.
 

·
Registered
nissan gq
Joined
·
2,115 Posts
Currently travelling Australia but my Nissan patrol has just lost all its power and can hardly set off.
In neutral it’s revs but bounces up the dial in a lumpy fashion.
blowing white smoke, with no warning lights on.
what could it be?
cheers
Australia is Big🦘,by narrowing it down a bit,you might be near someone who can help,so a ballpark location might be useful ? (y)
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Hi mate thanks for getting back to me, Engine oil looks fine and there’s no pressure in the rad. I think it must be injectors 😬
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Hard to say with the limited info you have given..
Check oil and water for cross contamination,
Is it making any more noise than normal?
Is the engine shaking around at idle?
Try undoing oil filler cap while engine is at idle, will make a bit of a mess but if there is excess pressure there, you may have a holed piston.
I’ll check that out tomorrow, had to book a night in a local motel 🤦🏼‍♂️
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
If there is no excess pressure in your radiator (check carefully after engine has cooled), and no mayonnaise like scum in it, then it could well be one or multiple bad injectors.

But check your fuel filter first. It may be clogged with crap and not flowing enough fuel, or could have water in it
I’m staring to think injectors
 

·
After Monday and Tuesday, even the calender says W
06 Td42ti coil cab chassis
Joined
·
16,755 Posts
Whats the verdict Harry?
 

·
Registered
Joined
·
2 Posts
Currently travelling Australia but my Nissan patrol has just lost all its power and can hardly set off.
In neutral it’s revs but bounces up the dial in a lumpy fashion.
blowing white smoke, with no warning lights on.
what could it be?
cheers

Narooma NSW
It's not a hose come off from the intercooler going to the turbo is it?
Happened to me the other day. No power, surging, blowing smoke. I thought it was up for big bucks. It was only a 4" hose had come of from under the intercooler to the turbo.
 
1 - 13 of 13 Posts
Top