Patrol 4x4 - Nissan Patrol Forum banner

1 - 6 of 6 Posts

·
Registered
Nissan patrol Gu Dx ute
Joined
·
127 Posts
Discussion Starter · #1 ·
Well I have been havIng problems with starting when the motor is hot or warm. It's starts fine when it cold. It's a 2006 td42i ute. I've replaced several fuel filters including after market ryco and genuine nissan which is on there now, I have also replaced the primer pump with a brand new one. And still got the same problem. The motor has only got 100000 ks on it so surely it's not the injector pump. I also replaced the hose clamps on the fuel lines to the injector pump ans the lift pump. But any suggestions would be greatly appreciated.
Regards jesse
 

·
Registered
Joined
·
3,955 Posts
check your glowplug timer. Little know fact: the plugs actually glow for longer than the light is lit..
 

·
Registered
nissan
Joined
·
511 Posts
Check and clean engine earthing point - it may be cranking too slow - good starter and battery are very important for starting hot diesel engine.
 

·
Registered
Nissan
Joined
·
526 Posts
x2 with Azotek. When I replaced the starter battery a couple of years back the Patrol started almost instantly everytime instead of hanging on the starter for a sometimes embarrassing amount of time.
 

·
Registered
Nissan patrol Gu Dx ute
Joined
·
127 Posts
Discussion Starter · #6 ·
Forgot to add I just bought a brand new 720 cca battery that was the first thin I did. the starter I had rebuilt about 1 year ago. Tightened the earth points to the battery as well.
 
1 - 6 of 6 Posts
Top