Patrol 4x4 - Nissan Patrol Forum banner

1 - 5 of 5 Posts

·
Registered
nissan
Joined
·
445 Posts
Discussion Starter · #1 ·
I can hear the pump priming when I turn on the ignition...but how reliable are the petrol pumps for the 4.8 GU?
The 2009 vehicle has 40,000km on it...surely the pump isn't dead already?
 

·
Registered
nissan
Joined
·
155 Posts
I hear mine prime every time I turn the ignition to on. Mines aftermarket as I changed it back to petrol from gas. I wouldn't worry too much. They ain't that dear so get a spare if your worried. The sun tank pump will run the engine fine also.

In a bad situation all you need to do is change the power wires over in the control box on the passenger side chassis rail.
 

·
Registered
nissan
Joined
·
155 Posts
Oh to add to that you need to 're run the fuel pickup hose to the sub tank. Sounds like a pain but ain't that bad
 

·
Registered
nissan
Joined
·
445 Posts
Discussion Starter · #4 ·
Thx.....my issue is related to my other post on why the car won't start but your comments are handy to know in any case! :)

1) To change my pump is a huge job because I have storage drawers in the back.
2) It's possible that my failure to start issue might be because of the flip key have a dodgy component.

The car goes for a service tomorrow...maybe they can shed some light on matters.
 

·
Registered
nissan
Joined
·
155 Posts
If you can hear the pump priming when you turn the ignition to on then I would look at other things but the mech should pick it up in the service
 
1 - 5 of 5 Posts
Top