Patrol 4x4 - Nissan Patrol Forum banner

1 - 8 of 8 Posts

·
Registered
nissan
Joined
·
4 Posts
Discussion Starter · #1 ·
I'm in the throws of a ZD30 to TD42Ti conversion. The TD42Ti donor engine was alleged to be a one owner, 155 000km, tested and reported to be running like a dream. Conversion complete, first start and there's a knock in the bottom end?? What could go wrong during the conversion to cause this? Is there any way an engine could be bodgied up to run well during testing and crap itself shortly after? Or is someone telling porkies? Thanks for reading.
 

·
Rogue
nissan gu patrol
Joined
·
20,226 Posts
Just thinking outside the box a bit..

Are you using new engine mounts? Is the motor hitting on anything?
 

·
Registered
nissan
Joined
·
4 Posts
Discussion Starter · #3 ·
All new mounts, hoses, belts, intercooler, turbo, pump, injectors and a heap of other stuff. Conversion done by a shop that does them all the time.
 

·
united fuel injection
Nissan
Joined
·
2,633 Posts
I would suggest the engine has been transported incorrectly and the sump has been pushed up and now the conrod is hitting it around number 2 cylinder .

Its very common as there isn't much clearance between them and the sump anyway .

Put youre hand on there when its running and you will feel it
 
  • Like
Reactions: Strzelk

·
Registered
nissan
Joined
·
4 Posts
Discussion Starter · #7 ·
You were right TD. The sump was damaged in transit causing the knock. Sump straightened - hopefully all good. Cheers
 
1 - 8 of 8 Posts
Top