Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
nissan GUIV
Joined
·
38 Posts
Discussion Starter · #1 ·
Have had a strange thing happen to me twice now about 12 months apart.

All power is lost (ie revs don't get much past 1500). Noticed a big puff of black smoke out of the exhaust when this happens.

You notice there is no growly sucking noise (higly technical terminology) through the snorkel which seems to indicate not enough air getting through (hence the black smoke) and one would assume the fuel mix is too rich. However, there is no blockage in the air lines.

Turned the car off to reset the ECU and everything back to normal.

it is almost like the ECU decides the air mix isn't right and changes something.

Have no idea what happens to cause this, but on both occasions it self righted itself with no ill-effects.

Anybody got any ideas?
 

·
Currently in PAD rehab
Joined
·
18,404 Posts
Cleaned your MAF sensor lately? Sounds like its playing up.

Being that it fixes itself its probably not the airfilter, but have you had a look at it also?

Edit - ohh just saw its a 2008 - Are they still under warranty?
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
48,269 Posts
Cleaned your MAF sensor lately? Sounds like its playing up.

Being that it fixes itself its probably not the airfilter, but have you had a look at it also?

Edit - ohh just saw its a 2008 - Are they still under warranty?
Agree with Dronus, but would definitely check air filter and would add in fuel filter check, the ECU will try to compensate for issues.
 

·
Registered
nissan GUIV
Joined
·
38 Posts
Discussion Starter · #4 ·
Thanks for the info.
Had a service recently. Would they normally clean the MAF sensor or check it then?

The recent issue happened when I was on the beach in very soft sand and gave it a few revs to get moving.

However, I will see about the MAF.

Cheers.
 
1 - 4 of 4 Posts
Top