Patrol 4x4 - Nissan Patrol Forum banner

1 - 7 of 7 Posts

·
obi 1 patientnewby !
nissan
Joined
·
495 Posts
Discussion Starter #1
Hopefully some has had a similar problem.
I am trying to increase boost to between 18 and 20 psi, but I cant get it over 15 psi, When I accelerate it over boostes to about 20 to 21psi so I don't think it is the Dawes valve,
The needle valve is fully closed and I have not been able to find any leaks and the VNT stop screw is 1/4 of a turn anti clockwise.
 

·
Registered
nissan
Joined
·
385 Posts
Don't rule out your Dawes valve. I had a similar problem. I pulled the Dawes valve apart and there was a tiny piece of crud on the seat. This was letting a small amount of boost pressure to leak off into the vacuum to the VNT actuator affecting boost control. It was much better after I cleaned it.
 

·
obi 1 patientnewby !
nissan
Joined
·
495 Posts
Discussion Starter #3
Thanks trev, I have cleaned the Dawes valve but that was some weeks ago, I will clean it again just to make sure.
 

·
Registered
nissan
Joined
·
385 Posts
Can I ask why you are aiming for such high boost? I thought 15 to 17 was enough for these engines. Without other mods, limp can be an issue with high boost settings.
Have you checked for any pinched hoses? When I was working on mine yesterday, I noticed a small vacuum hose had been squashed underneath the intercooler outlet hose. It was just about completely blocked off. You gotta be real dilligent when checking the hoses. 9 out of 10 problems are caused by faulty hoses.
 

·
obi 1 patientnewby !
nissan
Joined
·
495 Posts
Discussion Starter #5
I want more boost to help with high EGT, I have a HPD maf sensor housing so limp mode should not be a problem.
 

·
Registered
2003 zd30 manual wagon
Joined
·
530 Posts
Are your Dawes valve and boost gage connected to the same place with a t fitting?
I remember reading you need a second fitting on the intercooler pipes for the boost gage as some guys have had the issue of incorrect boost readings while Dawes is open.
I suspect I may have this issue and plan on fitting another fitting on the intercooler pipe so the boost gage has it's own
 
1 - 7 of 7 Posts
Top