Patrol 4x4 - Nissan Patrol Forum banner
1 - 12 of 12 Posts

·
Registered
nissan
Joined
·
19 Posts
Discussion Starter · #1 ·
Hey there fellow patrol drivers,
Was wandering if anyone might be able to give me som advice to a problem i am having with my 2001 patrol. Of late it has been lacking some power and low boost pressures. even driving up slight hills on the highway has me slowing down after hitting them at 100km/hr. I took my truck into nissan in Orange yesterday and they put it on the scan tool for me. when i picked it up they agreed with my issue of low boost pressures and told me my MAF was faulty. I checked my MAF at home and got 2.1v at idle so i changed it anyway with my spare one i had in the shed and then checked that one and got 2v at idle. all the other tests checked out ok on it as in 5v, 0v, battery voltage respectively. Took the patrol for a drive and found the problem had not fixed itself. Nissan also told me that it could be as a result of the boost control solenoid being faulty. checked vacuum and its all good plenty there. So is this when i buy a new solenoid and see how it goes or do the dawes setup? i havent blocked my egr yet and have only a boost gauge fitted on the outlet of the intercooler. did catch can mod 6 mths ago and found air cleaner to be a little cleaner replaced it yesterday with genuine nissan one as i always do. If i do decide to buy a new boost solenoid where is the best place to get one from or is the dawes setup the way to go and if so where can i get them from and instructions/diagrams of how to set it up properly so i can finally get some power and fuel economy back.
sick of replacing maf's 3rd one in 4 yrs so hopefully catch can will stop that problem.
Cheers
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
49,163 Posts
Hi Mate,
Surely Nissan should have been able to tell you if the switch is faulty. I'm quite sure others will have suggestions but firstly, is it auto or manual? what boost do you have at 1500, 2000 and 3000 with load? what vacuum did you get? I have 27hg I know others say they have higher but I have never been able to achieve it. The vanes on the turbo could be fouling, the diaphragm could be leaking, Where did you test the vacuum? maybe there is a leak after your test point. But again, Nissan should have been able to pinpoint all this.
 

·
Registered
nissan
Joined
·
19 Posts
Discussion Starter · #3 ·
Nissan tested the vacuum and said it was all good i actually dont have a vac gauge but pulled the line off the actuator on the turbo and it felt good. the arm moved then when i put it back on it retracted back up. boost usually sits around 5-10psi when cruising at 100k/hr. it is a manual. when i use cruise control on the highway the boost sits around 12-14psi.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
49,163 Posts
Nissan tested the vacuum and said it was all good i actually dont have a vac gauge but pulled the line off the actuator on the turbo and it felt good. the arm moved then when i put it back on it retracted back up. boost usually sits around 5-10psi when cruising at 100k/hr. it is a manual. when i use cruise control on the highway the boost sits around 12-14psi.
OK that all sounds quite reasonable, 12 to 14 is acceptable, what about the fuel filter.
 

·
Registered
nissan
Joined
·
19 Posts
Discussion Starter · #5 ·
yeh change the fuel filter every 10000km along with the air filter as well normal oil and filter every 5k.
i have heard the pnp switch mentioned on here before would it be worth changing that and if so how much would one of those set me back and what side of the g/box is it on. also was wandering would it be worth taking off the piping to the turbo and having a look or can u tell if the vanes are working by taking the vac line off the actuator and if its getting no boost then its safe to say they are working?
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
49,163 Posts
With the boost numbers your getting without EGR, vacuum switch and the Dawes setup I would not think there is too much wrong with the turbo vane operation.
 

·
Registered
nissan
Joined
·
19 Posts
Discussion Starter · #9 ·
will test the pnp switch this weekend drove the patrol to work today and cant get it above 14psi under load up a hill in 5th gear doing bout 90-95k/hr and will not accelerate is this about normal for a patrol? not a big hill but a gradual rise and longish hill! maybe it is just me and compared to another blokes patrol at work whose is stock standard mine just seems sluggish maybe it is to do with the 33's and roof rack and other gear on the truck. but i thought the exhaust would help that but now thinking about it it still has the standard cat on it only goes to 2.75" after the cat. would getting rid of the cat and putting in a straight dump pipe help a bit?
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
49,163 Posts
will test the pnp switch this weekend drove the patrol to work today and cant get it above 14psi under load up a hill in 5th gear doing bout 90-95k/hr and will not accelerate is this about normal for a patrol? not a big hill but a gradual rise and longish hill! maybe it is just me and compared to another blokes patrol at work whose is stock standard mine just seems sluggish maybe it is to do with the 33's and roof rack and other gear on the truck. but i thought the exhaust would help that but now thinking about it it still has the standard cat on it only goes to 2.75" after the cat. would getting rid of the cat and putting in a straight dump pipe help a bit?
I agree with Paul, don't think there's too much wrong with the boost considering. Now, with 33's, roof rack etc yes I would expect a loss. I'm a bit lazy and would have 300kg of stuff in the back but I always take the rack off when not in use as I notice the difference.

Had my 2 3/4" fitted including the hi flo cat and the difference is incredible, if you still have standard dump then that's quite a limiting factor for turbo spool up.
 

·
Registered
nissan
Joined
·
19 Posts
Discussion Starter · #12 ·
yeh cheers fella appreciate the advice might take the roof rack off and get the exhaust finally finished off with adaptor for the egt gauge then maybe will block the egr one day
 
1 - 12 of 12 Posts
Top