Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hello,

Strange but my main beam on the drivers side light has just stopped and the central locking has stopped at the same time, Dip'd beam is ok on both lights, just main on that one light, changed the bulb an no difference. Checked the fuses under the steering wheel, but they all seemed fine.
Only use the patrol for off roading so wouldnt shock me that some thing is covered in crap that i missed.

Any ideas?

Thanks chaps
 

·
Registered
nissan
Joined
·
10,915 Posts
mine done this ages ago. its the contacts in the stalk. i played around with mine till it worked which was good cept it kept contacting by itself and having one head light come on at 11pm and id only realise it about 630 the next morning.
i think a new one was about 100bucks
i guess the main thing. get a test light and on low beam test for power at that light. if ok. go to high beam and try find power. if you cant go the the stalk and again check for power at high beam. if you only find one wire with power and not 2 there is your problem. the stalk.
 

·
I SUNK 1
Nissan Patrol ST GQ30
Joined
·
960 Posts
hey there. i have a problem with the main beam on the right of my troll. my problem is with the plug on the glove if i wiggle it it works. i think i just have to tighten the contacts. maybe this will help, maybe not. as for the central locking, i'd just pull the switch apart and clean the contacts and throw a bit of lube on the door locking mechanisms.
 
1 - 4 of 4 Posts
Top