Patrol 4x4 - Nissan Patrol Forum banner
21 - 40 of 44 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #21 ·
That is interesting about the air leak at the hose fitting, if primer firmed quicker then there was an issue, they should have picked that up. Will be interesting to see what happens. One thing at a time mete.
Yeah, couldn't get a better angle to show you the hair line crack there, went to buy new house at Super cheap but they didn't have on that size. The mechanic was more focused on the fuel rail pressure than anything. I will call few more places tomorrow for injectors and valve adjustment tomorrow and go from there...on the flip side I wouldn't have to worry about fuel price This Easter :ROFLMAO:, can't understand how Gov thinks fuel excise cut is should be more for petrol and less for diesel, where as all the trucks n logistics works off diesel mostly.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
52,510 Posts
Yeah, couldn't get a better angle to show you the hair line crack there, went to buy new house at Super cheap but they didn't have on that size. The mechanic was more focused on the fuel rail pressure than anything. I will call few more places tomorrow for injectors and valve adjustment tomorrow and go from there...on the flip side I wouldn't have to worry about fuel price This Easter :ROFLMAO:, can't understand how Gov thinks fuel excise cut is should be more for petrol and less for diesel, where as all the trucks n logistics works off diesel mostly.
Cool. Re fuel, I filled up yesterday with BP Ultimate at $1.86L cheapest I've seen diesel around here for weeks. Funny, last fill was after a trip, first time EVER it cost me over $200 which meant I needed my PIN and I couldn't remember it, WTF?⁶
 

·
Registered
Nissan MK,GQ & now GU.
Joined
·
3,046 Posts
+Prime bulb from BCF, as the old one was shot. Takes at least 5 or pumps to be hard and stays hard for like 5 minutes.
This rings alarm bells for me.

Was this primer bulb installed on the car when you bought it? If so it is masking a problem and at a guess it could be the IP.

Hope I am wrong and good luck with it.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #24 ·
Cool. Re fuel, I filled up yesterday with BP Ultimate at $1.86L cheapest I've seen diesel around here for weeks. Funny, last fill was after a trip, first time EVER it cost me over $200 which meant I needed my PIN and I couldn't remember it, WTF?⁶
$200 mate f--k..Your Brian went into limp mode..I feel you
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #25 ·
This rings alarm bells for me.

Was this primer bulb installed on the car when you bought it? If so it is masking a problem and at a guess it could be the IP.

Hope I am wrong and good luck with it.
Thanks mate. Yeah car came like that. That's why I wasnt so keen on pump replacement yet, even though the mechanic is determined that's the cause. I am trying to eliminate one issue at a time as Geeyoutoo said..
 

·
Registered
Joined
·
28 Posts
G'day all.
After a lot of contemplation took the injectors off today. Will take the them to the injector specialist for testing and replaced with reconditioned ones if needed. 1 & 2 injectors were full of oil, may be because the O rings were twisted (pictured). Which makes me think oil was entering the combination chamber. Injector 3 was a bit stuck. Had to pry it out.
Motor vehicle Gas Auto part Metal Fuel line


Vehicle Motor vehicle Car Hood Automotive tire


Motor vehicle Automotive air manifold Engineering Machine Auto part


Product Cylinder Material property Gas Office supplies


Gas Auto part Machine Cylinder Pipe


Car Vehicle Motor vehicle Automotive lighting Cloud
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
52,510 Posts
@Alam not sure what happened there, quite a few double pics, I'll go through them tomorrow and sort them out for you.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
52,510 Posts
Can anyone please tell me why the injectors O rings are twisted like that? As if they didn't go in properly and what damage it could have done?
It is not that uncommon, sometimes happens on removal, I always use copious amounts of 'rubber grease' on them when I assemble.
Yeah sorry about that. In my end it shows normal when uploaded. But then shows double in post.
Can't explain that but I'll do a check today.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
52,510 Posts
G'day all.
After a lot of contemplation took the injectors off today. Will take the them to the injector specialist for testing and replaced with reconditioned ones if needed. 1 & 2 injectors were full of oil, may be because the O rings were twisted (pictured). Which makes me think oil was entering the combination chamber. Injector 3 was a bit stuck. Had to pry it out.
View attachment 541446

View attachment 541443

View attachment 541441

View attachment 541442

View attachment 541450

View attachment 541449
OK got the pics sorted, removing doubles and pics that were somehow merged, never seen that before. What system are you using to upload pics? Direct via forum is the best way, this works on phones PC's and Tablets.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #35 ·
OK got the pics sorted, removing doubles and pics that were somehow merged, never seen that before. What system are you using to upload pics? Direct via forum is the best way, this works on phones PC's and Tablets.
Thank you for that. Uploaded direct via website from my android phone.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
52,510 Posts
Thank you for that. Uploaded direct via website from my android phone.
Strange, never seen that before, some were joined somehow and were posting as one pic, there is a 10 pic limit per post, that was how more appeared to get through.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #37 ·
Evening all. Injectors were tested by the specialist today and all of them were within spec, working fine. So now it seems like the pump. Thanks to the awesome forum I found out the pump is not that hard to remove. Three bolts and off it comes. Any suggestions on the angel of approach? Looks a bit tight for anything! What bolts are those?Guess I have to take the intake hose off and go from there. Any advice will be highly appreciated.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
52,510 Posts
Evening all. Injectors were tested by the specialist today and all of them were within spec, working fine. So now it seems like the pump. Thanks to the awesome forum I found out the pump is not that hard to remove. Three bolts and off it comes. Any suggestions on the angel of approach? Looks a bit tight for anything! What bolts are those?Guess I have to take the intake hose off and go from there. Any advice will be highly appreciated.
You have downloaded the workshop manual haven't you?
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
52,510 Posts
View attachment 541716
I downloaded a bunch of things but couldn't find the actual workshop manual. Out of all those I found the above picture, that's all I got.
Look in my signature for link to manuals, there are 2 to choose from, to supp15 and to supp23.
 
21 - 40 of 44 Posts
Top