Patrol 4x4 - Nissan Patrol Forum banner

1 - 6 of 6 Posts

·
Registered
nissan
Joined
·
42 Posts
Discussion Starter #1
Hi guys,

Wondering if anyone has ran into a similar issue with Odometer screen being blank and not seeing the glow plug light come on and whether it was caused by a faulty relay..

Rebuilt the TD42T after sitting for four years with a dropped valve seat. I noticed the LCD Odometer didn't show anything when I installed the battery. Glow plug light doesn't come on either. The glow plugs are working fine but the dash seems to be blank. I've checked all fuses but can't find one directly related to dash lights and odometer.
Is there a relay that runs the dash warning lights and odometer that may have gone bad?

Any help would be greatly appreciated.

Cheers,

Jon.
 

·
Registered
nissan
Joined
·
42 Posts
Discussion Starter #3
Sorry, should've put that in the thread.
It's an 01' DX ute TD42T.
It fires up and runs fine but nothing on the dash..
I checked all the fuses the other day but will double check.
 

·
Premium Member
nissan
Joined
·
2,276 Posts
Fuse 28 in the fuse box inside the vehicle is the main instrument fuse but also double check fuse 24 as well.

I'm not sure about the odometer but hopefully one of these fuses is blown and that will solve your problem.

There is an ignition relay but if this was the problem things like your indicators and wipers also would not be working.
 

·
Registered
nissan
Joined
·
42 Posts
Discussion Starter #5
Bingo! Cheers for the help, Yendor. Turns out I must be going blind. Was indeed fuse 28. Everything works.
I've been eager to get the odometer reading. Turns out only 157,000 on the clock. Happy days.
Thanks again!
 

·
Premium Member
nissan
Joined
·
2,276 Posts
No worries mate.

Fuse 28 also protects the reverse light circuit. If the fuse blows again check the wiring to your reverse light and trailer plug.
 
1 - 6 of 6 Posts
Top