Patrol 4x4 - Nissan Patrol Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey Patrollers.
So I have this issue and to be honest I don't know where to start. I'll try to explain this as clear as possible. I'll set the scene first.
  • I have a rocker switch in the centre console to operate the rear aux light. When I hit the switch the aux light, and my reverse lights come on. Both also come on when I select reverse. The aux light is run via a relay mounted in the passenger side foot well.
  • I have an intercooler fan also running via a relay which is mounted in the OEM relay box, which I gutted many moons ago and put all my relays that were scattered around the engine bay into by using the guts from a second relay box from the wreckers. Worked really well. Nice and neat.
Automotive tire Motor vehicle Tire Bumper Font
Musical instrument Bullet Gadget Electronic device Technology


Here's the gremlin.
Keys out. I turn the aux light switch on, I then select reverse. The intercooler fan starts up, sub tank, air bag, doors, handbrake, oil pressure and battery lights up. Also the bulb check relay buzzes.
I do this exact procedure with the ignition on. All is good. Relay still buzzes though.
See YouTube Vid if it helps.
Now how long has it been doing this? Not sure as one would not really turn the aux light on and select reverse much in their time so it could have been like this for a long time.

Something else, which I'm not sure if its related. When I turn the ignition on, the bulb check relay buzzes, and goes off as soon as the car is running. From what I think I know, a buzzing relay is a poor earth.
Im just not sure where to look first.

Thank you for your time.

Edit : Just realised my pc has logged me in under a new name via FB or my email. Dunno how that happened. Mudski is my current user name.
 

·
Administrator
Y2KGUII ZD Wgn
Joined
·
50,168 Posts
Hey Patrollers.
So I have this issue and to be honest I don't know where to start. I'll try to explain this as clear as possible. I'll set the scene first.
  • I have a rocker switch in the centre console to operate the rear aux light. When I hit the switch the aux light, and my reverse lights come on. Both also come on when I select reverse. The aux light is run via a relay mounted in the passenger side foot well.
  • I have an intercooler fan also running via a relay which is mounted in the OEM relay box, which I gutted many moons ago and put all my relays that were scattered around the engine bay into by using the guts from a second relay box from the wreckers. Worked really well. Nice and neat.
View attachment 536762 View attachment 536763

Here's the gremlin.
Keys out. I turn the aux light switch on, I then select reverse. The intercooler fan starts up, sub tank, air bag, doors, handbrake, oil pressure and battery lights up. Also the bulb check relay buzzes.
I do this exact procedure with the ignition on. All is good. Relay still buzzes though.
See YouTube Vid if it helps.
Now how long has it been doing this? Not sure as one would not really turn the aux light on and select reverse much in their time so it could have been like this for a long time.

Something else, which I'm not sure if its related. When I turn the ignition on, the bulb check relay buzzes, and goes off as soon as the car is running. From what I think I know, a buzzing relay is a poor earth.
Im just not sure where to look first.

Thank you for your time.

Edit : Just realised my pc has logged me in under a new name via FB or my email. Dunno how that happened. Mudski is my current user name.
Was it fakebook or Google onetap that got at your username, if you like I can look at merhing them, let me know. Sorry can't help your electrical problem, complicated.

Re rear work light, I've had one for years, remember it is illegal for it to be operated from the drivers seat, mine has two points, if for some reason I get pulled over I can also start it from the back and keep the other secret....
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Was it fakebook or Google onetap that got at your username, if you like I can look at merhing them, let me know. Sorry can't help your electrical problem, complicated.

Re rear work light, I've had one for years, remember it is illegal for it to be operated from the drivers seat, mine has two points, if for some reason I get pulled over I can also start it from the back and keep the other secret....
Think it was Facebook. I wasn't really paying attention to be honest. If its a pain to merge don't worry mate.

I forgot about the legalites of that switch, but my Patrol got Engineered for all mods and they didn't pickup on that, the boost controller they did though, haha! Been stopped a couple of times by the good old Victorian Mansfield police without issue. She's a very clean rig and certainly not cop bait which is a good thing.
 

·
Premium Member
nissan
Joined
·
2,331 Posts
Sounds like the aux light switch isn't wired correctly. Battery positive for the aux switch is back feeding into the ignition circuit when the factory reverse light switch is on.

Buzzing relay could be caused by the alternator. Does the relay still buzz if you unplug the connector at the alternator?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Sounds like an earth issue to me and it’s feedbacking through the system when the key is off
Righto. Noted.

Sent from my iPhone using Tapatalk Pro
Sounds like the aux light switch isn't wired correctly. Battery positive for the aux switch is back feeding into the ignition circuit when the factory reverse light switch is on.
I was thinking to look at the switch first before i remove the relay box, which is a big PIA to do. I'll check that out
Buzzing relay could be caused by the alternator. Does the relay still buzz if you unplug the connector at the alternator?
I haven't done that, If the buzzing stops at least I know its the alternator for that issue.

I will try over the weekend and report back.

Thanks guys.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
I finally got back to the Patrol. Having a stuffed back I can only managed 30minutes tops at a time. So I unplugging the alternator the buzzing stops. So I know where that issue is coming from atleast.
The main issue still remains. I've remove the centre console, where the switch is housed, LHS kick panel to expose the relay and connections and this was a far as I could get for now. But having a quick look, I don't think I have the relay wired up right. I need to check. Hopefully I can get a look over the weekend
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
I think I need to go back to the start.
Would anyone have the schematics on this? The way it was supposed to be setup is, the aux light comes on when I select reverse, but I can also remotely switch the aux light on via the Carling switch in the centre console. i just need to double check that this is right or wrong, before I start to look elsewhere.

Thanks.
 

·
Premium Member
nissan
Joined
·
2,331 Posts
It can be wired numerous ways. Depends on lights used, one or two relays, blocking diode etc.

Would be much easier if you posted how you wired it. Then we could see if this was the problem and recommend changes.

Or you could try disconnecting the link between the factory reverse light circuit and the work light circuit.
 
1 - 10 of 10 Posts
Top