Patrol 4x4 - Nissan Patrol Forum banner
1 - 11 of 11 Posts

·
Registered
nissan patrol gu3
Joined
·
87 Posts
Discussion Starter · #1 · (Edited)
Hi, I have a GU series 3 Nissan Patrol 3.0 litre diesel, Every time I tow our 17 ft Caravan with the outside temp over 30 deg it over heats. The only way to cool the GU down is to open the windows & turn on the heater.

The standard nissan radiator has been fully cleaned out with rods and has no blockages. I also had the water pump & thermostat replaced 2 years ago.

I was told I need a larger multi core radiator & not the standard type that I have.

Is this correct? :anger:
 

·
Registered
nissan
Joined
·
502 Posts
hi mate is you patrol and auto by anychance? if so could need an external tranny cooler as they will help over run the rad.

if its running cooler with the heater one, you may need a larger capacity Rad.
 

·
Registered
nissan
Joined
·
2,003 Posts
Hmmmm... overheating is not one of the issues normally associated with the ZD30's and there would be thousands of them towing 17 foot vans (or bigger) around no probs.

As Sutto said, is it an auto?... if so a larger tranny cooler might help but is probably only covering up the symptom.

Perhaps check the fan clutch, a coolant/engine flush, maybe a tranny service if an auto.

Is the airflow thru the Rad OK or is it like mine and impeded by large spotties and winch controller? ... is the A/C condenser blocked with mud, spinifex, bugs or whatever?
 

·
Registered
Joined
·
166 Posts
Hi mate my o4 3l auto was getting very hot when towing up hills, I know that you had the radiator cleaned and rodded but how long ago i say this because i replaced the water pump and fan hub which are one piece and got the radiator checked and it was 90% blocked and never showed a problem around town etc, they tried to rod it but i ended up having to put a new one in NO problems now towing by 1.5t camper.

So you may need to check it again.
 

·
Registered
Joined
·
129 Posts
is the plastic shroud on the bottom of the radiator conecting the bull bar still there?

a mate had issues with a couple of 4.2 farm utes & the fix for him was to put the shroud back on as the after market bull bars did not have one. must direct more air through the rad i guess.

i have a sim problem with my 4.8 & need to get a custom shroud made as there was no shroud on mine when i brought it ..... i hope thats the issue anyway, like you i've doen the full rad service and aything over about 36deg and hills makes the needle move, slowing down to about 90kph is enough to help mine out but.
 

·
Go Hard or Go Home
Joined
·
3,197 Posts
As Sutto said, is it an auto?... if so a larger tranny cooler might help but is probably only covering up the symptom.

a coolant/engine flush, maybe a tranny service if an auto.

Is the airflow thru the Rad OK or is it like mine and impeded by large spotties and winch controller? ... is the A/C condenser blocked with mud, spinifex, bugs or whatever?
What these guys ^^^^^ said and I also agree with Reol. If the coolant has gone bad or is contaminated, it will block the radiator in no time and require rodding agian.
 

·
Registered
nissan patrol 2007 ti
Joined
·
55 Posts
Fraser1

Hi Mate, I had a similar problem and I ended up replacing the fluid in fan clutch which I got from Toyota actually and I overfilled it slightly as the diesel fitters I work with advised me and the problem was solved. It was very frustrating before I got to the bottom. As an aside in the mine where I work we fill them up with silastic and never have a problem again though diesel is cheap there!
 

·
Registered
nissan patrol gu3
Joined
·
87 Posts
Discussion Starter · #8 ·
hi mate is you patrol and auto by anychance? if so could need an external tranny cooler as they will help over run the rad.

if its running cooler with the heater one, you may need a larger capacity Rad.
No mines a MANUAL.
 

·
Registered
nissan patrol gu3
Joined
·
87 Posts
Discussion Starter · #9 ·
Fan seems well engaged however I do have an electric fan & large Spotlights.
 

·
Registered
nissan patrol gu3
Joined
·
87 Posts
Discussion Starter · #10 ·
Hi mate my o4 3l auto was getting very hot when towing up hills, I know that you had the radiator cleaned and rodded but how long ago i say this because i replaced the water pump and fan hub which are one piece and got the radiator checked and it was 90% blocked and never showed a problem around town etc, they tried to rod it but i ended up having to put a new one in NO problems now towing by 1.5t camper.

So you may need to check it again.
I had the radiator rodded, Flush out & new fluid only last summer for the same problem. Still not fix. Never a problem unless towing on above 30 deg days.
 

·
Registered
nissan patrol gu3
Joined
·
87 Posts
Discussion Starter · #11 ·
is the plastic shroud on the bottom of the radiator conecting the bull bar still there?

a mate had issues with a couple of 4.2 farm utes & the fix for him was to put the shroud back on as the after market bull bars did not have one. must direct more air through the rad i guess.

i have a sim problem with my 4.8 & need to get a custom shroud made as there was no shroud on mine when i brought it ..... i hope thats the issue anyway, like you i've doen the full rad service and aything over about 36deg and hills makes the needle move, slowing down to about 90kph is enough to help mine out but.
Yep plastic shroud is still in place.
 
1 - 11 of 11 Posts
Top