Patrol 4x4 - Nissan Patrol Forum banner

1 - 16 of 16 Posts

·
Registered
nissan
Joined
·
778 Posts
Discussion Starter #1
My truck will only rev to 3000 before it feels like it's out of legs, is this about right or should I be looking for some problems somewhere?
 

·
Rusty, but Trusty. Most of the time
nissan
Joined
·
1,185 Posts
Yeah mine seems to run out of go at about 3500, I would bet half the trouble is the stock exhaust, its crap!
 

·
KICKEN BACK IN THE BUSH
nissan gq
Joined
·
4,690 Posts
Maybe ya need the neck snappin power of the L28 !!!

Seriously tho,
Hows the fuel filters , all good ???
Fuel lines seem ok

NeRoK,
ya beat me by two fifths of f*ck on on the reply
 

·
Registered
nissan mk
Joined
·
970 Posts
My truck will only rev to 3000
Is that under power in a low gear or just giving it a rev?
Mine revs out freely to 3500 and would keep going if I didn't back off, I wouldn't like to blow it up.
 

·
Registered
nissan
Joined
·
778 Posts
Discussion Starter #7
Ive cleaned the primary filter in the fuel banjo and replaced the secondary filter, it will rev to 3000rpm with load I havent free reved it cause that is pointless, I've also adjusted the tappets to factory spec I'm thinking it needs more fuel, maybe it's been detuned.....
 

·
Registered
Joined
·
2,328 Posts
its gotta be fuel or air.

so on the fuel side, its would be fuel supply. so if there are no blockages in the lines, then i would say fuel flow is not adequate. this is the same with upgraded efi cars that often surpass the abilities of the stock pump.

unless something in the injector pump itself has gone wrong. im not very knowledgeable on them, but do they have any diaphrams or springs that may wear out, this could cause dramas.

if air, i could only imagine the turbo being the problem, but i think it would be a problem all over the rev range.
 

·
Registered
nissan
Joined
·
778 Posts
Discussion Starter #11
Yeah spot on nerok it has no fuel leaks anywhere and starts and idles perfect although does idle a little low,
I have one area of flexible plastic reinforced conduit from my pre filter to turbo maybe that is suckin in on itself..... I'll check it out on the weekend.
 

·
Registered
nissan mk
Joined
·
970 Posts
I took mine for a blast today 3800rpm in third up the hill 10psi on boost and going like a train.
(I just replaced my injectors)
Only problem was temp gauge went from 1/3 to 1/2 and beyond on the scale in only a minute or so. It came back to 1/3 again after a few minutes at under 3 grand.
Could prove to be a problem in sand driving anyone seen this??
 

·
KICKEN BACK IN THE BUSH
nissan gq
Joined
·
4,690 Posts
Outback,
When was the last time you had the radiator properly cleaned ???
Revving the pik handles goin up hills , anything will increase the water temp
If its just once in a while,wouldnt seem an issue
But IF it climbs and stays there, id be looking at a cooling problem

Sorry to go off topic, Tony
 

·
Registered
nissan MQ
Joined
·
185 Posts
Have you adjusted the valve clearances in the last 30 or 40,000km? I did mine the other week after 30,000km, after rebuilding motor, including reconditioning the cylinder head. The idle revs shot up from 500 to 1000, and the car just flew out of the blocks leaving all others behind. It just wanted to go, go, go. I had to wind back all three fuel valves on the LPG system to get it back under control. Its just the L28. But what a difference when you re-set the valves to proper specs. A lot of people, including myself, tend to forget this engine tune up job.
 

·
Registered
nissan
Joined
·
778 Posts
Discussion Starter #15
No worries Cory.
Millsy as stated in a previous post yes I have set valve clearances to stock specs and my engine is diesel.
Thanks for the comment anyway:)
 

·
Registered
Joined
·
2,328 Posts
Only problem was temp gauge went from 1/3 to 1/2 and beyond on the scale in only a minute or so. It came back to 1/3 again after a few minutes at under 3 grand.Could prove to be a problem in sand driving anyone seen this??
mine did that, sat just under half and went to 3/4 when pumping it hard. but that worked out to be ~100C, so not really a problem.
 
1 - 16 of 16 Posts
Top