Patrol 4x4 - Nissan Patrol Forum banner

1 - 4 of 4 Posts

·
Registered
GU RD28
Joined
·
109 Posts
Discussion Starter · #1 ·
Hey, new Y61 RD28 Patrol owner and been doing lots of tinkering to get this thing running reliably. Was running hot, sorted that (i think)

Noticed I was hitting the over boost release valve and the boost gauge was cruising past 15psi when I've got my foot down over 4k rpm until. Usually hwy 4th n 5th gear.

Step 1, turn down Turbosmart boost controller. Didn't make a difference, still over boosting on heavy accelerator pedal. Ended up turning it completely down to the - symbol and was still over boosting. Even tried all the way up, no different to boost level.

Step 2, plumb out the controller all together so it should run stock waste gate pressure. Still over boosting.

The gauge is reading 15+psi which should be much lower if it's tricking the waste gate to stay closed. So doubt it's a leak in the lines.

Dont really know what step 3 is? Something with the waste gate actuator?

EGTs 200-300 cruising. 350 up longer hill.

Thanks for the help
 

·
Registered
GU RD28
Joined
·
109 Posts
Discussion Starter · #2 ·
and if it's the wastagate not doing it's job, how do you go about testing it?
 

·
Registered
1998 2.8GU wagon
Joined
·
2,825 Posts
I get the same thing, caused by the wastegate seizing shut. First test the actuator by connecting a hand or foot pump to the actuator hose & see if it moves the wastegate. If it does, you will need to see what pressure it's operating at.
If it doesn't move, disconnect the rod from the wastegate (don't lose the little circlip) & see if you can operate the wastegate by hand. Mine seizes completly, so I spray it with WD40 & brake cleaner while moving it back & forth until it's free. Last time I sprayed Nickel anti-seize on the shaft, see how long that works for. If it doesn't fix it, I'll have to think about pulling the turbo off & fixing it properly. You will need to connect a pump to the wastegate & force it out a bit to get the rod back over the pin on the wastegate arm.
I normally don't worry too much about the overboosting as there isn't enough fuel to raise the EGTs & it's only on long hills when I've got the foot down. :cheers:
 

·
Registered
GU RD28
Joined
·
109 Posts
Discussion Starter · #4 ·
Thanks Wooly,

I think that's the exact problem I'm having. Got a torch in to have a look at the actuator hose and looks like it might be seized. Tried moving it with my hands, no luck. Unsure if that's possible but regardless, didnt move and looked scummy.

Whacked WD40 on it and went for a thrash to try free it up. No luck, still 15-20psi in high RPM.

I'll get some brake cleaner + nickel anti seize on it with the bike pump to see if I can free it and clean it up.

Hasn't been a big problem for the past few months on the street, but if you're on a slippery clay hill and need the top of 2nd gear to get anywhere then I'm worried it'll bang running 15-20psi.
 
1 - 4 of 4 Posts
Top