Patrol 4x4 - Nissan Patrol Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #1 ·
Hi guys, well since it's pissing down in Newy and I'm crook as a dog my offsider is having a truck maintenance day in the shed.
He has a tb42 turbo which he was just checking for boost leaks and I thought what the hey, give mine a look over.

Well turns out there is a massive leak at the back of the front housing(part which the waste gate bolts to), my off sider said it looks like there's bolts missing which clamp the housing together. Me not being in the know or what turbos look like I thought I'd ask the guru's.

I'm going to ring Matt when they open but just seeing if anyone could put up some pics.
Il try and up load mine.


Regardless if the turbo is all built correctly it's most certainly leaking bad!
And may explain my late boost issues, I thought it was pump related.
Anyway cheers guys
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #2 ·
Boost leaking in the between those 3 bolt holes on the inner rim if ya get me
 

·
Registered
Nissan/GU
Joined
·
1,083 Posts
By the looks of it those bolt holes are simply for mounting the waste gate actuator bracket, depending on how the turbo is oriented etc......?
 

·
Registered
nissan/patrol
Joined
·
370 Posts
The bolt holes are for the waste gate actuator bracket depending on how you have the housing orientated. The front cover is held on with a large circlip, you can see the black circlip above the holes. The circlip may not of been seated properly or put on the wrong way around (they have a bevelled edge) and the housing may have moved allowing the boost leak past the sealing oring between the CHRA and compressor cover. Or you may have a pinched oring which has let go. Either way I would be removing the turbo and checking.
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #7 ·
Hmm cool guys, well sooty's pic looks just like mine.
Il try and post up a vid of it doing it.
Won't be long.
 

·
Registered
nissan
Joined
·
2,919 Posts
Normally the holes for wastegate bracket on comp cover aren't drilled all the way through the housing, they are blind holes.
Only time you may get one that is not a blind hole, is if the turbo has been setup for either a top mount or dts manifold.
If somehow you do have one that's leaking, just put a bolt in it, M8x1.25.
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #9 ·
Righto, seams I can't load up the video to either photo bucket or YouTube!! Getting possess off lol
Can I send the vid to someone's phone and maybe help us out to up load it!?
Thanks fellas
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #10 ·
I meant 'pissed off'! ;-)
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #11 ·
UFI leaky turbo - YouTube

Let's hope that works!
That noise is not the motor running, it's all the air leaking out whilst under pressure! Water was sprayed to try and identify area.
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #12 ·
Right, spoke to Steve from UFI as Matt is away. He couldn't quite get his head around how we tested for leaks with the valve/bung adapter thing we made but once he realised that I had air blasting out of the circlip he said 'no no no, shouldn't be leaking from there' and suggested a pinched O ring. So they are sending a new O ring out in the mail and looks like I'm playing turbo pull aparts on the wknd..
Hopefully that's the problem, not real happy with te situation but happy with the service.
Il stay updated with results after the re fit.
Cheers
 

·
Registered
nissan
Joined
·
2,406 Posts
I'm struggling to see the problem...photos look normal...video (presumably taken stationary at idle) looks normal. Is there really a problem? If the compressor was leaking it would whistle like a ricer so loudly that people will turn their heads when you drive by.
 

·
Registered
Joined
·
1,035 Posts
I'm struggling to see the problem...photos look normal...video (presumably taken stationary at idle) looks normal. Is there really a problem? If the compressor was leaking it would whistle like a ricer so loudly that people will turn their heads when you drive by.
yeah i can't see a problem either. maybe try using a spray bottle with some soapy water in it so we can see where it bubbles on the video.
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #15 ·
Video was taken with car off and compressed air fed into the system after airbox to check for leaks. As you can hear that's a lot of air leaking out. I I understand it the whole system should hold pressure. My offsiders tb turbo holds pressure through the whole system-well apart from where it's leaking out of a few hose clamps etc.
Agree that pic looks fine, I wasn't sure if I was missing any clamps/bolts etc.
Air is pissing out between the front and middle housing. I had my off sider take the video and do the under car work as I'm struggling to move with this flu. As for the whistle it is quite loud, and like all things I'm not sure if it has gotten worse over time and just got used to it and it was like that to start with. It would explain a few boost issues I have. If there's anyone in Newy who's in the know I'm happy to pop round and show you what we did.
As for the water, it was soapy, just didn't hang around long enough due to the force of the air coming out.
Cheers
 

·
Registered
nissan patrol
Joined
·
1,708 Posts
How much air pressure did you put in the intake?...you had the regulator down to like 30psi? if you just jammed air in there, that would be bad
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #17 ·
Yeah not much hey, wasn't just ramming 100psi down its guts!
Had my hand on the compressor tyre pump being very gently. Like a quick 1sec stab every 5 secs or so with the reg turned right down.
It definitely didn't need much compressed air to leak, first baby squeeze and were both like 'where the hells that coming from'
From a 'feel of the hands' it's the circlip area. It was hard to get the phone videoing, spray the soapy water and torch accurate. I can take another vid today since I have some movement back in my body!
 

·
Registered
nissan
Joined
·
2,919 Posts
Well hopefully the circlip is orientated so it is not a turbo core out job (should be).
1/2hr job to change the Oring then.
 

·
Registered
Joined
·
750 Posts
Our td42 won't hold Pressure due to no throttle body or butterfly as petrols use. But the turbo should of cause. As Marty said its an easy job just take not of the bevel on the circlip as it's only one sided.
 

·
Registered
Joined
·
5,328 Posts
Discussion Starter · #20 ·
Yeah I'm hoping I can sort it out with out taking the turbo off. Depends how on the ball I'm feeling, this flu has flogged me...haven't been like this is years!
If I feel the need to take the turbs off it will be an excuse to take the water bung out of the block and give the cooling system/rad a good clean and service.

And yeah bottom line is there turbo should NOT leak any air especially not the amount it is! Mine might have been a Friday turbo, and if it was going to happen to anyone it would be me...
Should have bought a kowabunga ;-) flame suit on! Lol

I may receive the new o ring today, if so we will give it a crack and report back.
 
1 - 20 of 27 Posts
Top